Activate Button is disabled! Please help!

I cleared the keys a number of times, then logged in, but the Activate button in the license module stays deactivated.

I am using sql server 2016, how do i get the activation button to work?

Please help!

Install the License Module.

i did install the license module, but the activate button is disabled! could this be because i am running the server on windows server 2016?


Show a screenshot.

I rolled back to sql server 2014, and now am able to activate the license…

SambaPOS runs on SQL 2008 all the way up to 2016 without issue. I run SQL Express 2016 myself, as do many others.

The version of SQL would not cause an issue with Activation, nor the availability of the Activate button.

I wonder if Windows Server 2016 was preventing the activation button in some way from being enabled

No it wouldn’t. Somehow you deleted the license module. When you installed sambapos again it probably restored it.

1 Like

I’m having the exact same issue on a new terminal I am trying to install. Brand new installation and the activate button is grey. If I uninstall and reinstall I get exactly the same issue.

Any ideas?


Yes, I made a tutorial to activate your license. Have a look:

Activate your License

Thanks. In the end just reseting the database keys in samabamarket worked for me. It just seems weird because samabamarket says “I’ve changed my database, reset my keys” but I haven’t changed my database, it’s the same database the rest of the terminals are using so it seems strange that button had to be used at all.