Again. Printing Arabic language not working?

last time we changed the printer type to HTML and it worked fine. but today. something happened, now we cannot print Arabic language. actually we have have only “?” symbol for all characters even iin the template windows?
any ideas to solve this issue

last time when? Is this a new system?
Have you changed the character set?

it is v 5.1.56 system. last time is yesterday. i didnt change any thing. only thing changed was windows 10 updated.

That might be an issue related with windows fonts. Is windows language is Arabic? Do you experience any related issue outside SambaPOS? For example can you print Arabic letters with notepad?

Actually no. every thing in windows is fine. We didnt face the proplem in any other application. Only sambapos. Note that the encoding also didnt work even at the print template.
I tryed to change the chracter set but still not working.
I already have another application and it is working fine. And we looking to move to sambapos. We are still in the testing period so this is big issue you to fixe it.

i noted today an important issue,
when i changed the language of the windows to Arabic, i noted that the date in the top of sambapos platoforme become “?” symbol. that means that platform it self has a problem with Arabic language.

Setup a proper font in your printer template and it should appear fine.

  • Hope “Hamburger Restaurant” translated to Arabic fine :wink:

More info

1 Like

You are great man. its working. Thank you
and yes Hamburger Restaurant translated fine to Arabic :grinning: