All Terminals keep becoming unregistered


#21

No you need to view the actual table not properties of it. Besides that is not where the key is stored it is stored in the table AddonLicenses and it might look like this:

Obviously I erased my keys with paint.


#22

Of Course :smile:

Well I have gone to my addon section and this is what mine looks like.

I havent painted anything out as there is no key on show.

Does this mean I dont have a license here? or is there some other step I got to take before I get that little result box at the bottom of my Query.

Thanks all for your help


#23

Right click on the table then choose select top 1000. It looks like you typed up a query but did not execute it.

Or just press F5 to execute your query.


#24

Perfect. Mine does show my two purchased addons and they both have licenses.

So does that eliminate this a potential issue. If so what else can we do?

Thanks for your help.


#25

So is EVERY terminal showing unregistered?


#26

It is very intermittent, the most frequent ones to become unregistered is the most used one and the server, however the rest do unregister if the software closes and gets reopened. but till 1 and the server will unregister whilst being used.


#27

They are all connected via ethernet?


#28

They are all connected via ethernet directly to the router, so no switches or hubs inbetween. It cant be distances because it is the two closest systems that having this issue most frequently.


#29

And you do not have any automation for backups at all right? What version of SQL Server? Do they have internet access?


#30

I have no automations on any of the terminals or the server as I turned them off due to a suggestion from another post. We are running SQL 2014 and every single till has access to the internet as it is required for us to remote login if required. Otherwise it is an hour trip to get to the restaurant


#31

could this be a problem with the latest update as it only started occurring when we installed two new terminals which forced a whole system upgrade. This issue is still persistent and causing a lot of issues where now I have to log onto the systems before the customer is active that being between 8:30 onward and I have to register all systems together.

Any other suggestions would be great.

thanks all


#32

Doubtful but you could run a back up then uninstall sambapos and download and reinstall latest version then load back up. That might be worth a try.


#33

Hi Kendash,

I have spent hours re setting up the whole system. I decided to backup Samba from the software and also I ran a manual back up on the SQL management screen. I then uninstalled Samba software and SQL. I then ran updates on the server and rebooted. After that I reinstalled SQL and Samba then restored the Samba backup.

A lot of time and effort, but it seems ok at the moment. I will be monitoring it for a few days to hopefully see it working correctly again.

I will update this post further soon.


#34

Hi guys,

I have logged onto each terminal this morning and the issue is still occurring. What else can I do to resolve this issue as it is becoming a hassle and more of daily chore.

I am planning to upgrade another two restaurants soon which they are waiting for, however with this issue it is slowing me down and a bit of a concern as everything we have tried has not resolved it.

Any further help or guidance would be great.


#35

Its been occuring more frequently with a few of my clients too. However once reactivated it doesnt occur straight away but still occurs nonetheless.

Is there anywhere we can know why it keeps happening? Does the key suddenly change in the database?


#36

The Key for the License is tied to Database and the SambaMarket Login.


If I make a DB backup at my Venue, restore it on my Laptop, and happen to be logged in to SambaMarket with the incorrect User (a user registered for another DB - I think I have 4 IIRC), it will go into trial mode, because the User is registered with a different Key.

Are the Terminals (not the Server) Logged in?

Is the Server Logged in?

Curious to know, what happens if you:

  • Logout all Terminals, and leave them that way. The Key is in the DB anyway, which does not reside on the Terminals.

  • Reset Keys / Login on SERVER, and Activate, then Logout the Server and leave it that way.


#37

It usually occurs on the server terminals. Happens more often when a wundowd update occurs causing systemto restart, or when internet disconnects then reconnects frequently (caused by dropouts mainly).

I will test the market logout and see if that resolved this intermittent issue


#38

Just an update, the system has deactivated again.

I have just implemented the next option where the only account logged in is the server and all terminals are not logged in. It seems to have activated without requiring the activate button. I will monitor this and let you know if it goes down again.

thanks