Android Mobile Client - will it work with SambaPOS V5 or we need SambaPOS V5 Pro

I am trying to order 1 license Android Mobile Client and saw the statement below, so can someone confirm if Android Mobile Client will work with SambaPOS V5 or not?

(Annual Payment) Android Mobile Client for SambaPOS V5 Pro. One license activates only one device. Requires SambaPOS V5 Pro License

There is only sambapos v5 pro there is no such thing as just v5.

Thanks Jesse for confirming!

So, I tried to install (follow this document - 2.2.2. What is SambaPOS Messaging Server? How to Install? – SambaPOS Knowledgebase) the message server and got error when try to test connection. How can I tell what is wrong? Anything else that I need to configure or check? Thank you!

  • Installed the Messaging Server Service Tool
    C:\Program Files (x86)\SambaPOS5\Samba.MessagingServerServiceTool

  • Setup Firewall Inbound and Outbound Rules for port 9000

  • Restarted SambaPOS Messaging Server service and verified it’s running

  • Got error when test connection on both the Messaging Server itself (main computer) and another computer on the network which is connecting the the main computer just fine for Samba SQL database

for the message server port try 9000+ and see if you can connect once that’s changed

You mean add the “+” there? I did try that, but the “+” got removed automatically when I either save the settings or clicked on “Test Message Server Connection”. Anyway, it’s still failed to connect with or without the “+” for the port 9000

Sorry I wasn’t explicit - in the message server setup/installation


Oh, I did try that as well, and still same error. Any ideas?

got everything working now. Thank you!

1 Like

Perhaps you could share the solution in case someone finds this thread having the same issue.


  1. I uninstalled and reinstalled the messaging server using the C:\Program Files (x86)\SambaPOS5\Samba.MessagingServerServiceTool64
  2. I reboot the server
  3. On the tablet, instead of using the “http://PC_Name”, I just use the “PC_Name” without the “http://” and it connected
1 Like

The tablet fills that in for you. Glad you figured it out.