Caller ID Issue

Dear Emre/ Dear friends,

I am trying to make several Caller ID devices, including CTI USB COMET, work almost for a week but no success yet. I read each related post and tutorials, i watched all your tutorial videos, however i really dont know what im missing.

I wanted to upload images which shows putty result, usb modem and sambapos v3 configurations but it seems new users cant upload images.
The CID device is lenovo usb fax modem which has a conexant chipset.CID feature is activated by using putty and here ist the result:

RING

DATE = 1027
TIME = 1947
NMBR = 068120259645
NAME = O

RING

The problem is, sambapos seems to be accepting the device , however nothing happen when someone gives a call (no pop up)!

Could you please tell me where am i making a mistake?

Thank you for your kindly support.

What version of SambaPOS are you using?

Have you installed the Caller ID Add-on from Samba Market?

Dear Isaac ,
Thanks for your response!
Im using V3. Caller ID feature is installed. All necessary steps for take away deparment has been done. Generic Caller Id device is selected and right com port is also selected. Caller ID device works fine with other softwares as you can also see the result of putty output. When i make a call, sambapos does not response. There is no pop up!

.

Do you think that the problem might be related with 64 bit Windows ( in my case it is 64 Bit Win 8.1 Pro)?

Lenovo usb fax modem cid supports 64 bit windows by the way.

This topic might solve your issue.

Dear Emre,

I tried all these codes;

NMBR.=?[^0-9]+([0-9-\s]+)
NMBR.
=?[^0-9]+([0-9|-|/s]+)
NMBR.=?[^0-9]+([0-9]+)
NMBR.
=\s?([0-9-\s]+)

unfortunately none of them worked for me, specially with the last one, “NMBR.*=\s?([0-9-\s]+)”, i am having this error message “The Calling thread must be STA, because UI components require this”. The error message is always here when i close it , it closes sambapos also but without closing i am trying to modify Match Pattern, however after i save it locks Sambapos and i need to close it from Task Manager.

If any of you would have short time to check my .sdf database file, i will be really appreciate.

Thank you.

Below error message was highlighted on below link and it was fixed with version 4.1.28

Error Message: "The Calling thread must be STA, because UI components require this"

Dear morshed1,

I read your problem and the solution before. In my case there is no upgrade, im using sambapos V3 last version and the customer entity is setted up exactly same how Emre descriebt.

Thank you for your help but it is not a solution for me.

Is it V3? Is it possible to upgrade to V4?

Dear Emre,

I installed v4 to my laptop a week ago just for being sure that the problem has nothing to do with V3. The result is same. I used first a cheap cid than I bought Lenovo cid and finally I decided to buy cti usb comet from England and I bought 5 packs of them. With cti usb comet I have the same issue and behind this problem cti usb comet gives also no reaction in putty as well.