Cannot get my 2nd drawer to open with Open Drawer

Hi …

I am about to add a 2nd POS to the environment and encountered a strange behaviour of the mappings for OpenDrawer. I tried various mappings with departments or the specific terminal but without success.

If I use the following mapping on my TakeAway Terminal then the drawer of the POS Bar is opened:
till mapping

The Print Bill Job as attached does it correctly:


I would actually understand when the 2nd would not work due to the *s everywhere in the first line.

I tried with department and till and it just opens the drawer attached to the POS Bar Printer. I warned my cashier upfront that there might be some unexpected drawer openings.

Does anyone have a magic combination of mappings that make this work?

Attached for completeness action, rule, printer and terminal definition. … the printer works correctly …

drawer action drawer action open drawer rule printer def terminal

Had s similar issue this was my workaround:

Set them up as 2 separate print jobs and rules one mapped to your first epos and the second mapped to your new epos.
So have a open cash drawer 1 job and a open cash drawer 2 job
Clone your action and use the new one to run the cash drawer 2 job
Clone your rule and constrain it to the new epos also constrain the original rule to your original EPOS

1 Like

Thanks a lot … this is very helpful and that^s what I will do …