Customer display is a problem for multiple terminals

I have a Sam4s Titans260 terminal (Windows 10) with add-on 2-line customer screen (pole display) which connects via an RJ45 type cable into the COM3 port. I set this up to work with a welcome screen, items added with prices and totals etc. It has been working really well for weeks by setting up the printer as below:


BUT as soon as I tried connecting 2 other terminals onto the network, I hit a problem. The first terminal still works fine but the others ‘freeze’ as soon as the customer display rules are applied. If I unmap the customer display rules for these terminals they work fine. There are no errors in the error logs and the rule debugger looks fine. The same rules and ‘printer’ setup are being used on the first machine which is fine. I am thinking that the ‘COM3’ in the ‘printer share name/port name’ in the printer setup is being seen as a share name rather than a port name - so only one terminal will get to use it. I can only plug the customer display screen into COM3. So I need a way around this issue. I have tried every other way to set up this display but it only works with the port printer option.

I really hope someone can help me with this as I have completely run out of ideas…thanks!

Do all terminals have similar customer display on port 3?
Samba will always refer to local windows printer name/port
If you dont have display on every terminal you should add mapping in the print job for terminals with display only.

Yes, all the terminals are identical with customer displays.

Sambapos doesn’t appear to be referring to the local windows printer name/port. It looks like it is using the COM3 setting as a share name.

Have you shared COM port? Not even sure how you would do that without configuring it as a printer then sharing.
Last time I setup a customer display I setup that way and created a printer using COM port using generic printer driver and rather than using port printer just chose the name of the printer I had setup for the cport.

No we haven’t shared the COM port.

We have tried to set the customer display up as a printer on the com port with a generic driver but couldn’t get this to work with any of the ‘printer type’ settings on Sambapos. Can you remember what printer type you used and any other settings it needed? Thanks…

I just setup as com port with braud rate etc and used generic text printer driver that comes in windows.
It was a serial port rather than the rj45 type com port though

3 computers, 3 displays/printers … sharing the printer is obviously something you do NOT want to be doing.

Do each of the displays all pass the ECHO test from the Command Line to their respective displays? Verify that they are working at the Hardware and Software level first to eliminate the possibility of Windows/Drivers/Hardware problems. Open a Command Prompt on each of the computers and issue an ECHO command directed to the COM port to verify only the respective display produces output…

If that ^ is working on each computer, try this on the “Server” computer:

Clone the Display Printer twice and give each Printer a unique name…

Add Mappings to the Print Job(s) for each Terminal/Display…

1 Like

Have you tried “Rule Mapping”?
So the rules which apply to the print jobs for the port printer… In rule mapping you can specify the terminal your main server only. This way the rule wont apply to the other terminals except for the main terminal that has that pole display.

1 Like

Thanks for all the suggestions. I had already tried configuring separate printers for each terminal and separate rules and mapping…I had tried everything. The mistake I made was to assume that there wouldn’t be a hardware problem with 2 out of 3 brand new terminals that I bought. It turns out that the only one that was passing the correct voltage from the BIOS settings to the customer display panel was the one I set up first. When I tried an echo test, it became apparent that it really was a hardware problem and nothing to do with rule mapping or settings. Which is actually a relief because I thought I was beginning to understand how sambapos works…

So the 2 dodgy terminals are going back to the manufacturer for a fix up!

Thanks again for all your help, it is really appreciated.