Customer Loyality points/balance monthly report

@JTRTech you don’t need to use parameters for that report. {REPORT ENTITY DETAILS} already lists entities. Such config is useful if you need to map different reports. For example it can be listing tickets under each entities… In this case you can use parameters to map {REPORT ENTITY DETAILS} report to {REPORT TICKET DETAILS}…

thanks every one

it works emre except the E.balance :frowning:

E.Balance would be relating to the entity account balance not a custom entity data field which you implied you were using;

What are you doing, accounts or loyalty points?

im using the existing customer account to add the loyality balance to

E.Balance was added in v5.1.55 … ensure you are running latest version.

Actually my Version is V5.50, I’ll upgrade to V5.55 thanks

How can I exclude entities with a balance of 0?

I have tried
[Customers:1,1,1, 1] {REPORT ENTITY DETAILS:E.Name,EC.Address,EC.Phone,E.Balance:(ET=Customers) && E.Balance >= 0}

Try this.

[Customers:1,1,1, 1]
{REPORT ENTITY DETAILS:E.Name,EC.Address,EC.Phone,E.Balance.sum:(ET=Customers) && E.AccountId>0:::$4!=0}

No thats not working

I’ve tested it and works fine for me. Maybe it does not work for you for a reason. Can you show how it’s not working?

[Customers:1,1,1, 1]
{REPORT ENTITY DETAILS:EC.Customer,E.Name,EC.Address,E.Balance:(ET=Customers) && E.AccountId>0:::$4!=0}

If you compare yours with my sample you’ll see you don’t have .sum after balance.

Is there any documentation explaining what the :::$4!=0 is doing?
I want to try understand as much as I can so I can start contributing to this community rather than just asking for help all the time

Also why does removing Address or Phone break this?
I dont need the address and If i remove it it shows all entities with 0 balance.

[Customers:1, 1] {REPORT ENTITY DETAILS:E.Name,E.Balance.sum:(ET=Customers) && E.AccountId>0:::$4!=0}

But his works
[Customers:1,1,1, 1] {REPORT ENTITY DETAILS:E.Name,EC.anything,EC.anything2,E.Balance.sum:(ET=Customers) && E.AccountId>0:::$4!=0}

$4 !=0 means that column 4 which is E.Balance.sum does not equal 0

So if you remove address then all of sudden $4 is not valid…

Ok thanks that explains my previous question also because balance is now in column 2

1 Like

Can I ask what the three ::: are for.
Is this a generic syntax used when specifying column number?

No its specific syntax for the REPORT tags but leaving it blank means its not being used. Ill have to look up the various options give me a minute.

This is a quote from a thread Emre made but I copy pasted it here instead of quote so it would show the sections correctly.

{REPORT ORDER DETAILS:EN.Officer,O.Quantity.Sum::{0}:,}

So we have 5 sections here

  1. Tag Name.
  2. Fields.
  3. Expression (left empty)
  4. Line format (as we have only {0} first field displayed. We use that feature on data export templates.)
  5. Line delimiter. (,) means all lines delimited with , char.

As it is also a reporting tag it displays only values exists in reporting rage. Good for this sample but might be a disadvantage for some cases.


So your tag is leaving Line Format, Line delimiter empty and then its adding the $4!=0 expression which is probably new since that last explanation was made.

To make it easy to remember I’ve configured line delimiter char (1 letter) as always last section of the format after expression. So both {XX:F.Field:::$4>0:,} and {XX:F.Field::,} are valid.