Database backup help


#1

So I set up sambapos4 and then decided to download the sql express 2014 and I lost everything all my menu items and more. I tried to system restore my computer but it said my connection string was wrong. I have backups but when I click on them it says that current database does not support backup type. Help please I need my stuff back


#2

You should provide more details about your setup so we can assist better. Simply installing SQL Express 2014 would do nothing to SambaPOS. We need to know how you set it up originally was it CE, LocalDB? Also please read the guidelines for forum posts. Your post and subject was not appropriate for community involvement.

http://forum.sambapos.com/t/community-guidelines/3397


#3

It is set up as ce originally. I downloaded and installed the sql from one of the tutorials and once I completed every step I logged into sambapos4 and all the menu items and modifiers were blank again. I tried restoring from the zip backup I created earlier in the evening but was not successful. I did a system restore to try to correct whatever it was I did and now it says sambapos4 is working without a database.


#4

You should follow the second half of the 2014 tutorial that shows how to convert ce to script that can create the Schema


#5

Thank you. I will try that.