EDIT: Printer Name Is Invalid

Original problem solved because I’m an eejit, further problem below

ok, ive got as far as creating a file and it attempting to send.

I’m getting this in the log:

Message: The printer name is invalid

I feel I’m sooo close

Gotta set a share name even if its just a .

I did that. I put a . In there too and I get the same result

Edit: and I moved actions in and out to doubly check

Absolutely cannot get it to work

Maybe it needs to be single word printer name.

it seems to work on export (when I exported it to the live machine). No error log, but email isn’t being sent.

try basic email msg first then try attaching file. It could be that its not generating the file fast enough before email action sends. Your rule flow may be too fast for it. Try using Ticket Closed event for the email.

generally if it flows too quick itll say file not found even though the file is there as it was created a little after.

Ive put ticket closing event now and removed the file still nothing

So more than likely its your google aaccount not setup correctly. Try with just basic text?

its bizarre cos i received an email last night, had to allow unknown apps. Then i received 1 email and then nothing since lol

Ill go through it all again i think, double check it all. Ill get back if i get stuck still, but for now… website time

You are using a {DATE:X} tag in your Actions so when the file is generated it will be:


And when the file is attached it will be:


Even if you remove the seconds portion, and even the minutes portion, you will still always run the risk that the filename could be different between creation and attachment.

You should store the filename in a Program Setting, then create the file using the PS as the filename, then attach it using the PS as the filename. That way the filename will not be different between creating and attaching.

And you should know by now that hard-coding something like that into the Action is bad practice. Use a [:variable] like [:attachment] instead and then set the attachment action parameter in the Rule.

Also, The email action requires the CC field not be empty. Dumb I know, but it must have a value.

^^ Already done! :slight_smile:

Yes good idea about program setting. I actually took the ss out as it was a different filename.

ill cc it to someone random… maybe that’ll fire it to work?

Bizarrely it all worked less the file, but now it doesn’t throw an error but doesn’t send the email

Try switching all path backslashes \ to forward-slashes /

even with no file its not sending, with no error.

Im going to check through all of the settings in a bit as ken dash suggested above