Embedded IE html Viewer SSL issues

#1

Ok so the html viewer widget uses a dumbed down embedded Internet Explorer.
I need to access a local device and cant due to certificate issues.
https://192.168.1.201/zone.shtml

Is there any solutions to make the embedded IE just ignore?

0 Likes

#2

Do you have SSL in your localhost?
If not why you want to go https address of localhost?

1 Like

#3

It’s pretty unlikely you will be using https for local network device…
Certificates exprire for one and I have never seen a local device with a https certificate. Pretty with the option to setup to run on https but requiring user configuration

0 Likes

#4

Actually its 100% likely. This is pandora moog for business. This is a separate unit on the network that has your pay pandora service on it and you access it via web interface.

This is what it looks like in Chrome. We can access it from the desktop but want to access it from within Samba

This is how it looks within Samba.

If you use IE11 you can click on “proceed to site anyway” or something like that, but that is not an option in the embedded version within Samba POS

0 Likes

#5

It’s because there is no real certificate. Odd they would use https for that.

0 Likes

#6

Its the controller device thats plugged into our bose system in the media closet.
You have to log into it so I guess since there is a username and password involved, thats why the cert.
Yeah dumb. Maybe I can see if the device will have an update and maybe that will solve that.

0 Likes

#7

Username and password has nothing to do with it. It’s probably capable of a certificate for corporate use. I bet you can turn that off.

0 Likes

#8

I have looked all through the settings. I will have to check their forums and dig deeper, maybe put in a support ticket on that.

0 Likes

#9

Ok I understand now they are using a self signed certificate. You have a mood player right?

0 Likes

#10

You can edit security for ie to allow it.

0 Likes

#11

Its this
https://pandora.moodmedia.com/

And I edited and dumbed down IE on the computer but its different in Samba.

0 Likes

#12

You need to edit the correct one. I forget how it’s been a while but you can.

0 Likes

#13

Well please let me know. This is windos10 and I edited all the security for local and entranet sites in IE11 not edge.

0 Likes

#14

Try this https://www.ibm.com/support/knowledgecenter/en/SSYQBZ_9.6.1/com.ibm.rational.dwa.install.doc/topics/t_configureIEforSSL.html

0 Likes

#15

I have had routers etc which have option for self signed certificates but can be opted in/out of forced https.
Have you checked in the internet settings via explorer? Sure there is options about allowing unsecure/self signed certificates etc.

0 Likes

#16

I tried all that yesterday and it did not work.
Then of course IE wants to get pissy and lock up.

You get here and it locks up. Can not install the cert.

0 Likes

#17

Looking online you may still have issues with a self signed certificates as it’s not signed by a known provider.

0 Likes