Enitity screen wont load

Verify your Entity type is exactly “retour cash” (case-sensitive) and that the Entity Screen Name is exactly “retours” (case sensitive).

Try adding the Entity Type “retour cash” to the Ticket Type.

1 Like

just checked it all and they all are correctly written, i also added “retour cash” to entity type but also that didnt help :cry: for now i will downgrade back to .60 as i stated that its very important part for my restaurant but will post the full setup i used so it can be recreated and maybe that way the solution can be found :slight_smile:

so here is my setup
step 1 new account type

step 2 new entity type

step 3 new entity screen

step 4 new automation command

step 5 new action(with correct ss now :sweat_smile:)

step 6 new rule

this setup used to work in version .60 for some reason now in .62 it doesnt hope you guys can figure out whats wrong. thanks :slight_smile:

Entity screen name doesn’t match. You named the screen retours but the action has CHERCHER CLIENT

sorry my bad forgot to put setting back to how it used to be there as i tried to get the regular customer screen and see if that worked(which also didn’t work) will put right ss up right away :sweat_smile:

Also your ticket is paid. Typically it won t let navigation to entity if ticket is paid until you reopen ticket.

dont really understand, the ticket is still unpaid when we use the retour bouteille button cause for when it does happen that the ticket is paid before entering the retour bouteille entity i have setup the reopen ticket button/rule (Re-open Settled Ticket & Cancel Payments)

Show the mapping for the automation command

Your using the wrong action. You should use the navigate action. And set it to navigate to that entity screen

only navigate action i can find is the “navigate module” you mean that?

but how do i set to go to the right entity screen from here?

Set screen name in parameter.

tried it but that doesnt work, it just keep on ticket screen. tobe sure if it worked i tried it from navigation screen and then it just opens a ticket but it doesnt give me the requested entity screen

Is your ticket locked? How could navigate action create a ticket? You did something wrong. You sure you didn’t leave change ticket entity there?

no i checked all that(it used to work even with locked tables in previuos version)so far what i figured out it only wont open entity screen when im in a ticket

will check rule again can be i still have update state in there

Navigate module action will not create a ticket so did you try that action like I said? It works fine in 5.1.62 when I use it. So something is wrong on your setup.

If ticket is locked it won’t let you change entity.

so i checked it all this are my settings right now

here is my action i used

here is my rule with the action

here is the mapping of the automation command where i set on navigation just to test

here i press the retour button

which gives me the confirmation pop-up like it should

but then it gives this instead of the entity screen

hope this help cause im really confused right now why it doesnt work with me

Remove action from rule save it reopen rule and add action back save it again then try.

If that doesn’t work turn on rule debugger you could have conflicting automation. Paste result from rule debugger here.

same thing but did just noticed when i close the ticket that pops up it does go to the requested entity screen

So you have some kind of automation going on and it’s conflicting. I see your assigning a user as ticket tag. What automation are you using to do that?

Check for any execute automation command rules that have no custom constraints.

yeah tought maybe the user tag was conflicting but checked it out and even with that removed it still keeps doing the same thing will try the debugger see what that gives me :slight_smile: