Errors Importing Database

System was set up by Mark Wallace initially who did a great job. We had a software issue so system had to be wiped. I have managed to set SambaPOS up again and import the database fine and all is working. For future I wanted to set up a spare PC (thin client) in case of a hardware failure. I followed the same instructions on the install, database setup and when I import the database I get an error. I have checked and SQL Express 2014 is installed. Can anyone help?

Error??? Come on, more info please.
Will have a blind stap and guess it’s a permission issue.

He is using SQL LocalDB 2014, not SQL Express 2014.

He got this error when importing from local hard drive:

I told Majid to post on the forum as I don’t know what causes this, and it’s working fine on another system. I had this issue once before and when checking the identical backup on another PC it worked fine.

I don’t think it has anything to do with the database restore.

I was also able to restore via SSMS.

@Majid_Rafiq downloading and installing SSMS (SQL Server Management Studio) and using that to restore the database should work fine as it did when I had this error before. But it’s a big download and unnecessary just for this IMHO.

Apologies my first post here and I can’t see where to add pictures

Thanks Mark. Let’s see if anyone else has any other ideas if not can always go down this route

1 Like

Near s
I would Hazzard a guess it’s a state of some sort or is is SN and SV in database.
It’s same virsion of samba installed as what backup is from right?

Or perhaps it might be time related if date time format is different between machines? S seccond in some time formats.

In order to transfer your data from Local DB to SQL Express Server, you can follow steps of below document.

4.23. Transferring Data from Local DB to SQL Database

Yes V5 Pro. I managed to do the same task yesterday with no errors. It is a fresh Windows 10 install and SambaPOS.

Also time formats are the same I have checked both systems

Apologies I made a typing error earlier. have SQL LocalDB 2014 installed.

Yes but there are different versions/updates, beleive most recent update is 5.2.14.
You can check my double clicking logo in top left when logged in as admin to take out of full screen and version is in program titlebar.

Both version are the same. Used the same install file provided by Mark. Confirming they are both 5.2.14.

This is the sequence I follow and error I get after it says restoring database please wait

Capture2 Capture3 Capture4

What happens if you try to restore the backup in the list, rather than the zip? I know it may not be the correct backup, but would be interested to know if you get the same error.

I get the message

Database Restored Successfully. Please login now.

Try unzipping it and putting it in that same directory then restore it from the list.

No, you can’t unzip because then it won’t show up in the list. Just place the zip into the database backup folder then try restoring it from there.

When I place the zip file into that directory and try to restore I get the same error

Can you try just taking a new backup from the “working” system then restore from that?

If I do that it works fine.

1 Like