Excel file to sambapos

Thanks my friend now I know how use YAML in notepad++ so I fixing now my problem thanks very much

1 Like

Hi my friend I do a backup on V5 demo and now don’t let me open said invalid licence and when I try to restore the backup in other computer whit V5 this is what appear

You can not restore v5 database into an older version. You can login to www.sambamarket.com and clear your license key and reactivate license on the restored database.

License is only good for a single database so if you activate license on a database but then restore a different database it will not work until you clear license key and reactivate license on new database.

It will allow you to backup and restore the same database.

Ok. Now how can export the products to edit on notepad++ or YAML?

The same topic linked above contains a post by Emre on how to Export to YAML using Reports > Data Exports feature …

Here is an alternate method to Export/Import Products and Menus directly from/to the Database Tables, using SSMS…

1 Like

How can add Multiplier

  • Name: EZİNE PEYNİRİ KG
    GroupCode: ŞARKÜTERİ
    Barcode: 00001
    Portions:
    • Name: Normal
      Multiplier: 1000
      Price: 13
  • Name: POĞAÇA ADET
    GroupCode: UNLU MAMÜLLER
    Barcode: 00002
    Portions:

1 Like

Data Export ok, i want import multiplier 1000

Scale prices are automatically updated in SambaPOS V5 as the prices of the products change

I got this formulla ERROR:

That is a generic error message generated by Excel that provides no good information on the problem.

There is no way to know what is causing the error other than to understand how Excel’s CONCATENATE function works and compare it to the data from the cells that you are feeding in to it.

It looks like you are using CHAR[10] as the 3rd parameter, which is incorrect.
It should be be CHAR(10)

1 Like

Can you send me an excel file with this formulla? i’d tried many times and the same problem
Thanks you

No. I already gave you the formula.

You chose to edit it to contain CHAR[10] which is breaking it causing the error, because Excel does not accept that syntax.

It should be CHAR(10) not CHAR[10]

Thaks you for your quick response, but i got the same error.
In google sheets i got the same error.
if u can see, the ", in the formulla box appears highlighted.

reggards

No idea what the cause is then. It could be Region/Language related, don’t know.

1 Like

1 Like

Pretty sure there is more basic way to achieve what your aiming for which presumeably is a formatted yaml import string?

I created a link string in a spreadsheet to reference scanned invoices in this way.

Sure you can add strings in between, if not just use a seperate open, between and end set of cells and add the usuall $ in front of row and columns of cell reference to keep the reference static when dragging filling the formulas.

Just read further down and you just join cells with & and combine string/char & and wrap with quotes

hello all,

I am using Batch Creator in Batch Entity Editor to import the customer details please have a look in the screen print, its imported wrong, anyone can help

Look at the syntax example above the input box…

You set entity type and fields as CSV then each entity and details on a single line in CSV.
If missing a field on an perticular entity you would need to still put comma with nothing between just like normal CSV.

Yah, the problem is that your Data is not in the Format that is indicated you need to use:

that’s so complicated, sometimes I regrate that I use this program to manage my restaurant, I really value everyone supports but most of the time I don’t know what’s going on