Getting rusty in Message Server setting

Setup up a main unit of SambaPOS V5 on a SQL Server Express 2014

Set up message server on the same unit
Message Server Name: http://Ah-Wai-PC2
Message Server Port: 9000
(CHECKED) Auto Start Message Client

Green “Connected” is on

Terminal side

ALL SAME setting

But entity screens with tickets not refreshing?

What did I miss? Are there firewall settings I need to change?

tried to start the SQL Browser and SQLWriter services on the server-side with Task Manager but come back with “access denied” message

I was able to get it to refresh now but not sure which action I did that cures it. I disabled A FEW firewall settings and started SQLWriter services manually, SQL Browser still deny access.

BUT I get myself a bigger issue, the DB crashed upon restarting the machine - currently cannot start SambaPOS. SambaPOS returns msg saying cannot connect with current setting :frowning:

Good that I made an image earlier, and I can get back to ~exactly like last night. :slight_smile:

I retry the setting again. I disabled the Symantec Firewall completely and does not reconnect Window Firewall either, so basically there is no firewall at all at this time. The screens refreshes. Next step would be back to refine what is the proper Firewall settings to plug back the holes.

Will update when done.

You can find information on how to do it step by step on

1 Like

It’s really more basic than you thought. All you need to install is the SQL express db engine you don’t need any of the other services. Set SQL server browser to start automatic and that’s it. Set port 9000 allowed inbound and outbound for tcp on the firewall rules.

1 Like

I followed the Kb but did not realize the Symantec is still active in my test machine :frowning: even though the deployed machine’s firewall is properly set up.

BTW, I found the KB very well written and easy to follow in setting up most of the SambaPOS. A great job.

YES. That’s my final setting too.

I need NOT to overthink(overreact) too much when something happened. My confusion started when I have put a wrong connection string in new terminal. When it does not start right I started to overreact and question whether message has a part in that. :stuck_out_tongue: