How do I changed the "Void" title from the report?

I use Samba POS V4. Now I want to change the name of ‘Void’ from the button and the report. Now I also enable to change the name from the button but could not from the report.anybody can help me to solve this issue. Here I also attached a screen shot…

Version 4 Default reports are not able to be customized however the Void is a State. So you would need to change the State name from Void to something else.

Proceed with caution however because changing states could mess up other parts of your system. You should study states before messing with them.

Hello Kendash,
Thanks for your response. But I couldn’t find the Void in to state. Is there any mistake?
Screen Shot is given below…

Anybody can give any solution to solve this problem?

A state doesn’t need to be in the list you show,
You would only define a state there if you wanted to specify how it is shown/reported.

States are set/changed in actions in rules.
There would be couple of rules needing changing at least HOWEVR as kendash said this is not something to take lightly as altering states can cause other problems.
Allot of things are based on states…

Be sure to backup before attempting!

There would be at least two rules with void i can think of in which would be the void and cancel void rules.
However there would be several of there places where adjustments would be needed.

For one the mapping of automation commands
Your printer template will have a section specified for void so as not to print void orders

I’m not at my computer to check for others but be careful and backup before trying.

1 Like

Hello JTRTech,
I have already change in to the two rules one is ‘Void’ and another is ‘Void Cancel’ and two Automation Commands one is ‘Void’ and another is ‘Cancel Void’. Another thing I already change in Automation Command in Cancel Void in Mappings where Visible State was ‘Void’.

These two Screen Shot will clear more…


Show what you have changed in the rules.

I’ll hazard a guess you changed the rule name and not the action.

Yes I have attached all screen shot where I edited.






You haven’t shown the rules you adjusted!!

1 Like

in the English language a VOID is NOT a discount. Are you sure you want to call it a discount?


In the screen shot I indicate the adjusted portion with red border. I just changed the text with ‘*Discount’ instead of ‘Void’. I hope you will clear with this reply.

In English Void = is not *Discount. But here I will use something extra-ordinary word. So I surely used the word ‘*Discount’ instead of ‘Void’.

You did not show the changes you made in rules,
All you have done is change the button header to discount rather than void!

Not quite sure what your saying… Discount and void are completely different, discount is closer to gift than void…

I don’t know or not find, where I should change or made the rule. I just want to change the name of the word ‘Void’. So I used ‘*Discount’ (Star Discount) not Discount. Please count this a meaningless word. I don’t want to change the action of the Void, just want to rename Void in all places.

You cant just change the word. VOID is an order state. YOu must change the Action inside the rule that is setting the VOID state.

I suggest you study States here:

Let me know please that can I remove/switch off the Void and create a new rule as Void action with different name? So that Void will not shown in the POS and the report.

I just did. You should read that link.

OK! I will try my best.

These are the default Rules for Void and Cancel Void.

You need to change them to support *Discount (or whatever word you want to use for the State)…

1 Like