How to get Gift Ticket details on ítem sales report

I wonder how to make MI item sales report to show items that have been gifted cause when I gift any item the work period report only show the amount but I would like to see the detail on my item sales report

Try this.

[Gift Items:5, 2, 2]
{REPORT ORDER DETAILS:O.MenuItemName,O.Quantity.Sum.desc,O.Quantity.Percent:(ODI=True) and (OCP=False)}

ODI Stands of Order Decrease Inventory and OCP Stands for Order Calculate Price. So it lists gift items that are not voided.

We can use Custom Report features to calculate average price and the value of Gift items. It might be something like…

[Gift Items Value:2, 1, 1, 1]
{REPORT ORDER DETAILS:O.MenuItemName,O.Quantity.Sum.desc,O.Price,[$2*$3]:(ODI=True) and (OCP=False)}
>Total|{REPORT ORDER DETAILS:O.Quantity.Sum,O.Price.Average,([O.Quantity]*[O.Price]).sum:(ODI=True) and (OCP=False)}

You can insert these reports in work period report or create a separate gift items report.


Nice!!! thanks you
I have another question i was following the gift configuration in order to crate a wastage button but I fail

Merma = wastage
when I try to wastage and click merma it wastages all the items.
I cant select only one item and click merma because doesnt show when i clicked

I try to follow the same gitf configuration:
create merma status, merma automation comand, action and rule same as gift but no luck hope some one can help

Thats because you have your merma button mapped to ticket so that only applies to ticket functions. The reason why it disappears when you select an order is because the list of buttons displays on the left hand side and buttons that affect ORDER lines

Unselect items from ticket and the ticket function buttons reappear

So what you need to do is open the automation command settings for the Merma button, select mapping and change the position of where you want the button to appear. At the moment it should be mapped to Ticket (the far right column in the mapping settings) click the drop down and select ORDER LINE instead and click save

Now go back to the pos screen and merma should no longer show on the left hand side, add an order to the ticket and the press the order to select it, this will now display the order line buttons on the left hand side and you Merma button should now be there

Select either one order line or multiple and press Merma and that should perform your wastage setup however you that setup from that button press

1 Like

Ok I did not realise that I fix it now so I can see the merma button but when I click merma but it doesn´t do anything this is my configuration:

Why have you got two update order actions in the rule? They both fire at the same time so possibly the first action is firing and your merma action isnt

after clicking merma I can not see any result as when i click on void

Did you not read my previous response about two update order actions in the same rule

1 Like

sorry I’m kind of new don’t know what you mean jj

In this image you have 2 actions:

Update Order
Update Order Mermer State

So when you press the Merma button its trying to use both actions you listed there. But as the actions in a rule work at the same time (they do not happen in the order they are listed) it could be that the first action of Update Order is working but as it working at the same time as the Mermer action the Mermer action doesnt work

Try removing the Update Order action from that rule, save it and try the mermer button on the pos screen again. If it still doesnt work then well need to look at your rules and actions in more detail

Sorry didn’t read your previous post for some reason OK I’ll follow your suggestion thanks for your help

I tried your suggestion but still the same result merma button it is not working
i had the update order and order merma state bacause I was following the same gift configuration that I have installed on my pc by default

can you expand the actions in that rule you have posted above (click the little down arrow on the right hand side of both the blue action boxes) so we can see the settings