How to make Entity Screen Full Screen! V4 and V5

This has been ask so many time and @Jesse answer it many times too but searched but doesn’t seem to have tutorial about this.
So, here it is quick video how to make Entity Screen to fullscreen (not exactly fullscreen but fill all the space).

Thanks to Kendash for the tip.


  1. Enable Design Mode
  2. Select Widget
  3. Right Click and select Property
  4. Set X and Y to 0
  5. Adjust Width to maximum (your screen resolution width mine is 800x1280.)
  6. Adjust Height until you get fullscreen.

While playing with this, I noticed that sometime widget won’t save. I have to delete the widget and add it again. It seem it only save once.


It saves if you exit design mode immediately after making change.

1 Like

If I follow this and make the entity screen either full screen or force it to use full width, will it then stop the entity screen being responsive?

I want the entity screen to use the full width of the screen / SambaPOS window while still being responsive to changes of screen / window size.

This is Custom Screen, Layout was not available back then.

If you want to make floor plan (cant use layout), you have to do this on each terminal then exit design mode and exit SampaPOS to save local setting.

1 Like

I’ve tried this on one computer, but it changes on all terminals.

Is there a way for each terminal to choose its own full screen resolution?

I have 1024x1280 in kitchen but 1366x766 on server and many screens are smaller.

You would want to enable layout mode.