Integrator's GraphQL API Guide


#41

Wow looks fantastic. Looks a lot like the McDonald’s self serve create your taste kiosks


#42

Would definitely love to test this here in Australia


#43

This has credit card integration? Is it a Web app or separate windows program? Also where did you get the hardware from?


#44

Yes this has a payment integration in Turkey with Ingenico hardware. And it is a web app. This is a tailor made hardware for us.


#45

Web app made by you guys, if so can you release any of the source code examples?


#46

@the133448 We probably won’t release the source code but it is based on PM-POS & GraphQL with some changes on Menu and CSS. That is mostly graphic design work. We need to do some work on SambaPOS side to sync menus. After completing that we may release it.


#47

https://forum.sambapos.com/uploads/default/original/3X/3/9/39b30aacdafc9eb9cfc0169e02b19a58b928f10e.png

I don’t have the field for “Application Type”, I can’t input “Javascript”


#48

Have you refreshed to the lastest update?


#49

It would be nice to see some nicer transitons when pressing the buttons considering its a customer expereince, so its not focused on speed of order entry. But altogether it looks great and a lot like the mcdoanlds create your taste Kiosks. https://www.youtube.com/watch?v=rPGBowJJVAI


#50

@emre Thnaks for the update it was long wait to use Gloria, but here I cannot setup correct as we have three tutorials my question is do we still need to install init-s -y , I cannot find those tutorials . or just need to follow the latest procedures? it would be good if the tutorial will be from scratch to complete . as when I used few months ago it worked partially now its confused me . pls need step by step guide if anyone can. or kind request that maintain the tutorials in same topic post .


#51

I followed the tutorial in here and it works just fine. You need to explain which tutorials you are referring too as not working.

In fact I installed the config task and setup the script according to this very thread and it all works. I also followed his very detailed tutorial to set it to run as a service.

Heck every tutorial he has made about Gloria Food has worked. Some are newer and contain newer script which makes sense if you want to try his latest work then try that. Remember its not an official sambapos solution so you will need to do some work yourself to get it to work.


#52

@Jesse Thank you so I just want to confirm that ignore old posts, and just this new post will work fine?


#53

I’m using the latest version, 5.1.62


#54

The screenshot was from Beta.

The parameters and available options have changed in the Release.

Set the parameters as shown below. You might need to set the Auth Type to “All Functions”:


#55

On the login screen in “server:8080/login”, whenever I type the correct user/pass, nothing happens. But when I deliberately type in incorrect user/pass combinations, I get an error message that says “try again.”

Also in “server:8080”, my screen doesn’t display “Authorization has been denied for this request.” It shows this:


#56

Did you change the port to 8080 instead of 9000 like tutorial shows? Did you setup message server to allow graphql server like tutorial shows?


#57

I thought we could use any port we wanted

This is from the server computer.


#58

Did you setup app permissions for graphiql in the users/applications settings ?


#59


#60

Hi @emre
my knowing about this developer tools and the commands and all that i dont understand
i only come at this point and here is my first complication. I cant restart the Message Server… and i dont know if this is important at this point…
im searching for answers i would like to follow these steps but i do not get very far…

thx for answers!