Integrator's GraphQL API Guide


#81

I restarted the messaging server after resetting the password for the Administrator profile, I still get the error 500 but ONLY when I add the client_id key to the request, without the id it just returns a supply a client id error. Everything is on the local network


#82

Be sure you are running the latest 5.1.62.

To be sure, download it now and install it.


#83

Wait a minute. Shouldn’t the URL for Login be:

http://localhost:9000/Login

EDIT: NO. It should be /Token as you have. (the /Login path is only used with GraphiQL).


BTW, have you tried login using GraphiQL by chance?


#84

Done a complete reinstall of the POS, changed the MessageServer settings and made admin have password of admin. Testing now


#85

I will attempt a login there quickly


#86

Just says try again and Authorization has been denied for this request.

I have set up GraphiQL as an application in Samba already but cant sign on


#87

I don’t know for sure, but for GraphiQL, the client_id might be specific (ie. hard-coded), so try this:


Also, run the Messaging Server Service Tool and verify that there is a PLUS (+) symbol at the end of the Port Number …


Also recommended that the Messaging Service is run using a local Administrative account …


#88

Followed your steps to the pixel, still no luck. Even did the Local Account for the service


#89

It shouldn’t matter if you are doing this all locally, but have you tried turning off Windows Firewall?

The thing is, if you can’t login to GraphiQL using the /Login path, then getting Gloria working is nigh impossible.


#90

Firewall is off, still wont work. I will do some extra testing with a few other things and report back if I find anything


#91

PS it works because several of us are using it daily. You have missed something somewhere. Keep looking maybe you can find it.


#92

Loaded up SambaPOS today to have another shot at using this. Got it working except how do I set an order as delivered. Also when I want to select an order and click Display Ticket on the right it does not show up.


#93

Hi Everyone Hope you are well.
is anyone who is using PM-POS ?
its a great app really appreciate. i need to discuss something please let me who are using.
Thanks


#94

Its a beta project not meant for real use not that it cant be. What is your question?


#95

i want know the android app and pmpos is same ?


#96

No they are not the same. They both use GraphQL but no they are different. Android App is officially supported although it is in beta atm. PMPOS was just a proof of concept.


#97

Android app is a native android app/program, PMPOS is a website/web interface.
Android app is created and by SambaPOS where as PMPOS is a community based project which in theory you (with experience) can rewrite/create your own using the API by modifying the code.


#98

okay got it thank you so much both of you.
is any demo available of android app if i want to check on my mobile
THanks


#99

Whenever I type something on here, I always get this error, whether I’m on the server computer or a local computer.


#100

Well you don’t always get that same error. That error is specifically saying it can’t find task type Null which makes sense considering You typed incomplete syntax. You can’t just type anything it has to be correct syntax.