Invalid object name 'ReportSettings'


#1

Hi
Just started fiddling about trying to figure out a way to add ingredients for allergy advice labels when I ran into a strange problem. If I try to add Product Tags, rename Portions, add info to an already existing product tag SambaPOS crashes with the error Invalid object name ‘ReportSettings’. I’m running the latest version 5.2.16 on Win 10 with SQL Server 2017. I’ve not ran into this issue before, but I’ve not had to change anything for a couple of months. I’m going to revert back to an old version to see if that fixes it and report back, but thought I should mention it here.
Alex


#2

Can you re-install metrik for SambaPOS?


#3

Apologies for the very late reply, on that day both my file server and backup server died within hours of each other, agh.
Anyway yes I had installed Metrik previously to see if it was something we could use, but as it didn’t seem to work I uninstalled it from both the Till and my phone. I’ve now reinstalled metrik on the Till and updated to SambaPOS 5.2.18, but unfortunately the problem still persists.
Alex


#4

Is it giving the same error? Did you uninstall all old versions of metrik? Sambaconnect is all you need to install.


#5

Please uninstall metriK Connect application from your computer and re-install it. Thats all for solving this.


#6

I have to admit, all I’ve ever installed on the Till is the SambaConnect software which gives you the QR code for the Metrik software on my phone/ I’ve never installed any Metrik software on the actual Till.
Anyway I’m happy to report that after uninstalling SambaConnect again the replication reinitialises with no errors, phew. Thank you for your help.