Inventory's products disappear after adding in V5

So I believe that V5 now have product’ menu in inventory section dedicated for stock ingredient tracking purpose right? But If I were to add inventory’s product in there, it will immidiately disappear when I close and re-open inventory’s product section again.

Maybe my writing explaination doesn’t make sense, sorry about that XD.

Here’s what i meant

Picture 1, adding inventory product

Picture 2, saved, so far so good

Picture 3, but if I close & re-open inventory product tab, then it disappears

Picture 4, or more like hidden because if I type the name into the search box then it re-appears. But still…

having said that, I probably won’t personally use inventory’s product for my setup because inventory’s item seems to do the job for me just fine :stuck_out_tongue: .

I have looked at this and it doesn’t do that for me. I can create products and they stay there. I even tried closing Sambapos and restarting and its still there.

Try downloading 5.1.59 again and see if the issue persists. I know Emre uploaded a refresh not too long ago.

Latest release should be 4-13-2016 your on an older refresh.

Not 100% sure if that will fix it but I know mine is not doing that.

Hm, I’ve updated sambapos but it’s still not working :confused:
I can still use it in the recipe though.

Weird I couldn’t reproduce it too. Can you PM me a zip file of your backup?

It is really strange… Is it Inventory > Products screen?

yup that’s the one i’m talking about. product name isjust a random name I came up for a test though :stuck_out_tongue:. So were you able to reproduce the issue with my DB ? or was it just something wrong with my computer ?

It seems working fine for me. Adding new products also seems working fine too.

I suspect that may relate with layout files. Can you try temporarily renaming [my documents]\SambaPOS5\Layouts folder and starting SambaPOS? It might be a good idea to backup layouts folder before changing anything.

renamed and move layout somewhere else, but still no go :frowning:.

Anything else I should try :/?

To provide more context, I tried and successfully replicated this issue at both my home and restaurant (two different computers). So it baffles me that the DB I pm’ed you didn’t encounter any issue…

The restaurant’s POS is running windows 8.1 and my home is running windows 7 by the way.

Wow very strange lol. I tried it on 3 PC’s and all 3 work just fine.

LoL. Did you set Display Limit Warning setting as 0 in SambaSettings.txt file?

what even is that XD?

Click Local Settings > Display App Path and PM me a zip file of sambasettings.txt. I can check that.

I think I found the culprit :smiley: . All I had to do was clicking “change sort order” and the product popups again (I probably accidentally pressed it sometimes ago unknowingly. Anyone can test if this is replicable? Not sure if that’s how it should work though :laughing:

Nope that doesnt do anything on mine either. I think your computer is just possessed.

Ok, I don’t know what’s going on anymore lol. For now I’ll settle with being able to see Inventory’s product by giving up the ability to change sort order :neutral_face:

It’s 1AM here and I don’t like the sound of that :sweat:.

Better go sleep now I guess.:kissing:

1 Like

I guess I found why that is happening. I’ll test & fix it when I get back to my dev machine.


Sorry to dig this up @emre but I’m having this issue again and the previous ‘change sort order’ temporary fix also didn’t work this time. Is there any way I can fix this at the moment? Or did you find why it was happening so I can attempt to correct it ?( assuming its the DB’s fault and I broke it somehow)