Issue with Price change change all order prices

@emre possible bug?

When doing a price change ALL order change instead of just the selected order here is my rule and actions, ive selected All Orders=False but it still updates all orders



Be sure “Clear Selection” setting not enabled for “Price Override” command.

I have de selected “Clear Selection” but it still updates all orders

i also closed samba and restarted but no change, all orders get updated

So when you gift an item does all items gifts?

PS: Sorry Clear Selection was something else. You can re-enable it.

Edit: Try clearing “Update All Orders” setting instead of setting a variable.

I don’t use the gift function

It started doing it so I amended my action and set the variable for “update all orders” as it was originally blank thinking that was the issue

I’ll redo the action again leaving that blank and see if I still have the issue

It only started doing it after changing the way I do price changes but it was using the same action so don’t understand why all of a sudden it’s updating all orders

I’ll try again

1 Like

same issue, i left Update all orders blank but it still updates all orders

can you send me a backup?

ill describe my flow

  1. add orders to ticket
  2. select an order on the screen which fires a rule to open the "order options"menu
  3. Press Price override
  4. Select a command value which updates the order state
  5. popup keyboard appears to enter new price
  6. The selected order line updates its order state and price

@emre ive found the issue, its something to do with selecting command values from the auto command

If the auto command values are blank as below

then price change works correctly on the 1 item selected

I needed the command values so i could use that screen that appears to update the order state, so if i add these back as below, price change ignores the selected order and changes all orders

Add orders, select an order, press one of the command buttons eg Manager Override, enter price and the outcome is all orders updated

Try enabling execute once setting?

Appears to work fine for me.

I made some unreleased changes so I’m not sure if I fixed it already while fixing something else. I’ll be glad if you can test it with the next update.

Yep i tried that as well but still changed all orders

Thanks @emre I’ll test again with new release :grinning:

1 Like

This now seems to work fine thanks @emre :grinning:

1 Like