Login screen issue - having to touch the screen first to allow a mag card to swipe a login on first load


#17

I’ll test when I get back im out of town shopping for supplies ATM.


#18

Ive just done some testing and if start samba with double click on desktop only, but if click a third time on desktop or samba shortcut you get samba with orange border on enter pin but keyboard doesnt input to field.

When you ‘grab’ focus if it very first thing before loading screen loads? It seems like the focus maybe is being requested imediatly on aplication start before any window opens so any additional click then takes focus back off samba.


#19

Just been doing some tests and typing PIN code worked straight away. i then shut down and and restarted and tried mag card swipe and it didnt work. i shut down again and tried scanning a barcode and that didnt work.

i shut down again and tried entering PIN via keyboard and it worked

i then repeatedly shut down a restarted and mag card swipe starting working first time without the need to touch the screen first. It seems if you shut down and restart instantly mag card work, but when the pos is shutdown for a long period when you then restart you need to touch screen first for mag card swipe to work

@markjw said hes had clients complain about the same issue too so it isnt just restricted to my system


#20

So it’s random whatever it is.


#21

Seems to be when left a longer period between shut down and starts


#22

Yes I can type pincode from keyboard just fine.


#23

I expect next update will solve the issue @RickH but I’m really curious what steals the focus from SambaPOS. Maybe it just relates with how you start the application as @JTRTech tested.


#24

I was trying that as I find additional clicks/taps is common for touch screens in my experience.
Because it takes a few moments for that loading screen to open and the pointer doesn’t show loading etc I regularly see people try to double click samba icon again thinking that first time didn’t work.


#25

Yeah so true, people are SO impatient! The number of times I have had people complain “SambaPOS is slow” because it takes a few seconds to load… :frowning: I actually make a point during training to explain to them that it is normal it can take 20 seconds or so to load (on a typical POS terminal). People these days expect everything loads like an app on their phone. :stuck_out_tongue:

During those seconds they repeatedly double click the SambaPOS icon…


#26

Something Windows didn’t solved properly to date…

That was the #1 issue on SambaPOS 1.0 … Even it takes just 2 seconds to load some people intentionally clicks on the icon 4-5 times just to be ensure they could double clicked on it. That’s why we don’t allow starting multiple apps by default.

However I never noticed that steals window focus… I could only reproduced it by starting a notepad with SambaPOS. I hope this solves the issue.


#27

It doesn’t help that on a touch screen sometimes you are not sure it registered a double click, even myself I’ve double tapped an icon for it to not register.


#28

I have it set to single click so I don’t have that issue


#29

It is much more a touch screen issue.
Are you able to delay the request for focus untill after the loading screen shows?


#30

We do it when PIN box receives the keyboard input focus but unfortunately request for focus does not guarantee Windows will focus. I’ve used a Windows API level solution for that. I hope that will fix the issue.

@VehbiEmiroglu can we update beta?


#31

OK i will update today


#32

I uploaded a fresh build. Please look to the Beta topic


#33

@emre tested on new release and still have same issue, need to touch screen first to allow mag card to swipe on inital login


#34

Well I really can’t think anything else. As I’ve demonstrated it captures focus even while I’m typing in notepad. If we can find a way to reproduce this I can try to fix that.


#35

OK I gave it another go and changed something else for the next update. Please let me know if it makes a difference or not.


#36

Will do, I’ve not missed another update have I since you made this new change?