Message server not update client


I turn off all firewall.
Example for simulation
5 store at same place at shoping center
Each store run different businnes restaurant
5 store connect to 1 instance server sql server with 5 database at data center office at 1 store.
Each store has multi order station and cashier
My question, can samba message server tool run at each cashier computer for each store.


The Messaging Server Service should only be running on the SERVER computer. It should NOT be running on the Client Terminals.


Yes, thank you, so i must change plan to implement it


Out of interest is that really the case?
Have always done that way just because it worked like that but in this senario you would then have 5 databases all using the same message server but running of different databases… is that going to work correctly?
I was under the impression message server was not directly connected to the database/server but more of a central ‘ping’ point for inter terminal communication? Yes you only want one message server on a site but taking your comments would that mean if you forget the multi database part of the question, if I had a normal singal site/database that you couldnt have a (not that you would want to) SQL server and a message server on two ‘server’ machines?


Though the Message Server and DB are not necessarily completely related, they are supposed to be communicating about a single DB. If you have multiple DBs running on a single Server, you should be running multiple Messaging Services, 1 per DB, so that the Clients don’t get confused about which DB (ie. Restaurant) they are talking about.

Because you can only run the Messaging Service once per machine, you obviously can’t run it multiple times on the same Server, even though it contains multiple DBs. However, you could use a “Client” machine from one of the Restaurants to run the Service on, while ensuring the Port is different for each installation or DB that is involved.

I suppose in fact, the statement “you should only run the Messaging Service on the Service” is not really accurate, since it could be running on any machine, including a Client. The point being though, is that you should only have 1 Message Server per DB… no matter where it resides.

In a single DB setup, it makes sense to run the Messaging Service on the same “Server” that contains the DB. That said, the Messaging Service could actually be running on a Client machine instead. But the point remains - the Service should only be running once per installation; that is, you wouldn’t run the Service on the Server, and then have it running on each of the Clients as well.

I hope you understand the point I am getting at here.

1 Like

Is there a tool to test whether the Message server and a client is connected.
Also if set the Auto Start Message Client “on” using port 9000, 8080, 9080 and so forth
when I start the SambaPOS v5, it will say “Message Server Not Connected”
I will have to go in again to deselect the Auto Start, exit the SambaPOS and press
Start Client Now". However, after I press it no messages to tell whether it has in fact connected or not.


There should be a green message on bottle of samba saying connected.


Problem solved by using the Samba.MessagingServerServiceTool.exe to set the port address to, say, 9000. It was defaulted to 8383.

Thanks you time to try helping me. Now my next task would be trying the RDP on Android - hope not too much issue.


Hey all. Hoping to get to the bottom of an on going issue. I have Sambapos up and running, and its mostly good things. I have 4 terminals plus the kitchen display. I am using SQL Server with a windows 7 and 10 mix (server is Windows 7). I have been having an issue with my kitchen display. It will, completely at random, send multiple duplicate orders and they appear on the screen as a new ticket on the display. It does this at random with different tables and different menu items. It will show it on any terminal when you bring up the Kitchen Display GUI. For a while I was dealing with it because a reboot would stop this issue (reboot of the server computer). But now it does it almost every day. It does it if we are busy or slow. Also this happens after the ticket is paid and settled. I am posting this here because I have never been able to get message server working, and I believe the issue is related to that. I have to set the kitchen display screen to refresh every 3 seconds or it does not update. If a new table is added it wont update across all terminals if the table display is open. I have also tested the message server by sending a simple pop up message to the terminals with a message saying Hello. Nothing happens. The terminals have the green connected message at bottom . Message server is running on the server computer only with the port set to 9000. Terminals are connected by the terminals ip address. So far I have not had any answers as to why it is not working and any help would be appreciated. The ongoing kitchen display issues are a real nightmare, and with mothers day tomorrow, our kitchen is in trouble. Also I have 1 terminal that does not update to the KD system unless another terminal sends a ticket. Meaning if I enter an order on Terminal B, nothing shows up in display UNLESS another order is entered on another terminal. Once that order is entered it will show BOTH orders as new tickets in the kitchen display system.


If you configured that Broadcast properly (ie. the other Topic indicates you installed MSTC) and still nothing appears, then Messaging Server is not working properly.

Although the “Connected” message is supposed to indicate that the Terminal is connected with the Messaging Server, it is not indicative of proper Messaging Server configuration. For example, the Terminal might be connected to itself rather than the “real global” service on the Server machine.

With those things in mind, best guess is that you have Message Server running on more than 1 Terminal, even if you believe this is not the case.

Turn off all Firewall programs, including Windows (Defender) Firewall.

Check Windows Services on all Terminals to ensure SambaPOS MessagingServer Service is installed and running on only 1 machine - the Server.

Check the Windows Tool Tray on the Task Bar on all Terminals to ensure NONE of them have a red apple icon in the Tray. If a Terminal has that apple, then it is running a Message Server in standalone mode. You need to avoid this on all machines, including the Server machine. Use the icon to terminate the program, and ensure your Terminals do not have that program in their Startup folder.

Check the SambaPOS Version on all Terminals to ensure they are all running v5.2.3. Double-click on the top-left of the title bar to reveal the version and build date.

Check the Clock on all Terminals to ensure they are all set to the proper date and time.

Playing Kitchen notification sounds for new orders

Ok, i have checked all the terminals to ensure they meet those requirements. They do.


Expand the hidden icons in the Task Bar Tool Tray by clicking the double-up-arrow to be sure there is no little red apple icon hiding there (all machines).



Yes, I confirmed it on all machines, no hidden icon indicating message server


Anything else that could be causing this issue? All machines are on the same network and all on same workgroup. They all see each other and can communicate between each other. No other services are running except system services and Sambapos.


Maybe a Port conflict? You could try changing the Messaging Server port …


On the Server, run the MessagingServer Service tool to set the Port to something else, for example: 9898+ (include the + symbol)

C:\Program Files (x86)\SambaPOS5\Samba.MessagingServerServiceTool.exe


Terminals (all)

On each Terminal, including the Server, within SambaPOS, in:

Manage > Settings > Local Settings > Message Server
  • Set Message Server Name to the IP Address of the Server (ie.
  • Set Message Server Port to 9898 (do NOT include the + symbol).
  • Ensure Auto Start Message Client is checked.
  • Click Save.
  • Shut down SambaPOS and restart it.


OK, I dont know how I missed this. I had the wrong port set IN Sambapos on the server. I fixed it and it worked.


And now it would appear that we are back around to the original issue, Kitchen Display does not update with new orders unless auto refresh interval is set to say, 3 seconds. If it is not set, the display will not update unless you exit and reopen.



LOL, that’s what you get for not showing screenshots. Good chance someone reading here could have spotted that right away.

That makes no sense. With Messaging working properly, it should update automatically with:

  • Auto Refresh : checked
  • Auto Refresh Interval : 0

I think I finially got it to work. I turned off every computer on the network and rebooted the router. Once router came back up I turned on the server, started Samba then booted the clients. Works now!

1 Like