Message server not update client


#21

Anything else that could be causing this issue? All machines are on the same network and all on same workgroup. They all see each other and can communicate between each other. No other services are running except system services and Sambapos.


#22

Maybe a Port conflict? You could try changing the Messaging Server port …

Server

On the Server, run the MessagingServer Service tool to set the Port to something else, for example: 9898+ (include the + symbol)

C:\Program Files (x86)\SambaPOS5\Samba.MessagingServerServiceTool.exe

image


Terminals (all)

On each Terminal, including the Server, within SambaPOS, in:

Manage > Settings > Local Settings > Message Server
  • Set Message Server Name to the IP Address of the Server (ie. http://192.168.1.50).
  • Set Message Server Port to 9898 (do NOT include the + symbol).
  • Ensure Auto Start Message Client is checked.
  • Click Save.
  • Shut down SambaPOS and restart it.


#25

OK, I dont know how I missed this. I had the wrong port set IN Sambapos on the server. I fixed it and it worked.


#26

And now it would appear that we are back around to the original issue, Kitchen Display does not update with new orders unless auto refresh interval is set to say, 3 seconds. If it is not set, the display will not update unless you exit and reopen.


#27


#28

LOL, that’s what you get for not showing screenshots. Good chance someone reading here could have spotted that right away.

That makes no sense. With Messaging working properly, it should update automatically with:

  • Auto Refresh : checked
  • Auto Refresh Interval : 0

#29

I think I finially got it to work. I turned off every computer on the network and rebooted the router. Once router came back up I turned on the server, started Samba then booted the clients. Works now!