Multi session successful but with some minor network issues


I’ve successfully created a connection between my second desktop and a laptop connecting to the main computer where the Sambapos and it database reside. It was successful. I actually find that if you disable homegroup and set it where users need to input username password to connect fixed my problem with connecting sambapos database. I’m not sure if this does the trick but it works for me. Here goes my problem.

For example, it was connected 30 mins ago where I just login and check the sales and then I quit the Sambapos. This was done on my laptop. Then on the same laptop, I launched Sambapos and it failed. The data string pop up window and I just leave it as the same. But the strange thing is my second desktop is still connected to the main computer and still working properly. On my laptop, I tried for 3 times with 5 minutes interval as I want to check if it was my network problem OR it was trying hard to connect to the main computer. It was successful on the 3rd. This happened many times, including the times where I need to restart my modem and it was working fine afterward.

Is there a way to fix this? Like will a fixed IP/DNS allow smoother access for computer on the same network? Or I need to get another router (I’m using wireless router at the moment).

Currently, the SQL is on mixed mode authentications. By the way, the second desktop and laptop with much better specs does browse much more faster and smooth than the main computer with N3540 intel processor even though the database was on the main. I had posted a video on how horrible my Sambapos delayed and it was much better experience now.

There is a number of things that can cause issues for ‘client’ machines.
In most cases it ends up being a network issue.
Kendash did a good tutorial on solving conectivity issues but cant find it.

Usual first steps are;

  • Can you ping the ‘server’ machine
  • Is firewall blocking it (try turning off to test)
  • Can you connect with SQL Manager
  • Try using SQL authentication rather than windows
    The list goes on

As for network…
Ensure everything is on a static IP address.
Try using IP addess rather than PC name in the connection string.
Wifi devices ensure all power saving settings are off.

1 Like

Whats this about Kendash?

Just kidding JTR!
But @teantattle2014 you just should move away from mixed auth’ and use SQL - then most of your issues will disappear IMO. I have spent so much time working through Windows Auth thats it not just worth it especially when you can just use the TCP Express Bus.

Once you eliminate Windows then you can work on any Router issues.


That would be why I couldn’t find it in his topics list when looking for a link LOL
His big SQL tutorial was mainly about installing and setting up SQL and upgrading from compact :smile:

1 Like


Thanks you all masters here for answering my questions! Appreciated!
I have not had any issues so far for connections but sometimes when you leave it for quite some time idle (from another terminal connecting to the main thru wifi network), it would freeze for 15-30 secs if you’re lucky, you can continue BUT if you’re not lucky :stuck_out_tongue: then the program would freeze and crash windows appeared and you have to restart the program again.

Would a seperate router just for the terminals works better? because i’m now using the router that is shared with customers and also my workers that uses their smartphone to go online. :frowning:

That generally relates with your power saving settings. Try setting harddisk / CPU not to sleep when power saving activates. SambaPOS have no control on how it operates.

Yes it would work better. I remember these topics already discussed on forum so you can use search function to find more info about them.

1 Like

thanks emre! cheers~! :wink:


I am facing similar issues to what you have. The get connection successful, but some times connection string error pops up. after some trials sometime it works, but it is not predictable.

Thanks …

Is this on a wifi device?

Yes it is on wifi …

One sugestion would be to set static IP on the wireless device.

Wired will always be more reliable and excluding tablets I would always reconmend spending the extra time and money hard wiring any device which has a fixed location.

Another tip which can sometimes help if the router which is resolving local host Names is not the best would be to replace the server host name with its network IP address. I’ve the first part of connection string might look something like this:\SAMBAPOS
Obviously that is subject to your network config and IP range.

If your issue is on startup of device and using dhcp it could be that samba is loading before dhcp has correctly assigned IP to the device so another this might be if you have samba as a startup program to set a delay on that so the device has properly started, loaded and connected before samba starts looking for the server.