New install, just show "loading" and does nothing

After install, stuck the the loading screen, never get to the keypad sign in part.

Tried both 2014 localDB, and 2017 localDB

Win10 64bit
Samba 5.3 - the one I just download from this morning.

No need to worry about the hardware, I have installed prior versions in this laptop before. Besides Win auto-updates, I cannot remember if I ever change the OS from the last SambaPOS install.

Anyone idea what could have been the reason?

Is there anything in the log file?

log file in where?

the files in programdata does not have a log file

the default location will be "%USERPROFILE%\My Documents\SambaPOS5\log.txt"

Error msg

Type: System.Data.SqlClient.SqlException
Message: CREATE FILE encountered operating system error 5(Access is denied.) while attempting to open or create the physical file ‘C:\Users\adminSambaPOS5.mdf’.
CREATE DATABASE failed. Some file names listed could not be created. Check related errors.
Source: .Net SqlClient Data Provider

Maybe I need to change some settings or move some files out of \users\ directory?

Also I found the file name seems odd - there is missing a \ between admin and SambaPOS5.mdf

Open C:\ProgramData\SAMBAPOS\SambaPOS5\SambaSettings.txt

Where you see C:\Users\adminSambaPOS5.mdf change it to C:\Users\admin\SambaPOS5.mdf then save the file. Try and start SambaPOS and see if that works.

On another note, it’s highly recommended one uses SQL Server. The Express version is free. For Windows 10 SQL Server Express 2017 should do.

cannot file the phrase in the file.

I will try server version afterwards if the localDB still has issue. I just uninstall 2019 Express. was trying to make a lighter system.

I’d stick with 2017. If you haven’t saved any passwords when installing, can you post the file here?

I’m looking for that part between <ConnectionString </ConnectionString>

the connection string was empty. Need to stop for the night, TOO TIRED. Will come back tomorrow if problem persists. Will try to uninstall manually delete all remnants and see what happen.

Thanks for the help

<ConnectionString / >

If there is no data between <ConnectionString > and </ConnectionString> SambaPOS doesn’t what to connect to.

This seems to be an issue with your installation on more than one occasion.

I recommend you reinstall SambaPOS. Select only what is shown:

Then install SQL Server Express 2017. Login to SambaPOS with the default Admin password of 1234 and follow the directions for configuration in the first post of the thread SambaPOS Database Configuration under " SQL Server Configuration".

Finally got it to work after a numerous times of uninstalling, manual deleting remnants of prior installs. Currently set it to use the SQL server 2019 as new stuff going forward from SambaPOS will demand it.

I believe the main reason is when installing/uninstalling the same machine with different options will leave things things behind that confuse the subsequent install. In my case, I believe it was the .NET Framework or C++ runtime. During uninstalling of SambaPOS, it did not uninstall the runtime along with it. But different version of the .NET Framework or C++ runtime may have caused the issues.


Yes there is an issue with it. I think it’s Microsoft’s fault. Uninstall of the distribution and install sambapos let it install new version of distribution And you should be fine.

1 Like

I tried to recreate the same situation to make sure I won’t fall into the same situation again. Here is the initial report

In another machine,
1)Installing with Sample Data and 2017 LocalDB will hang
2)Installing with Sample Data and 2014 LocalDB will work(the default settings in the lastest SambaPOS 5.3 download.

2a)Installing SQL Express 2019 after Trial-2 and connect using the build in connection string utility in SambaPOS works. Note: since the SQL Express 2019 is not the one used in the, the database instance name is not the same as in the kb.

** Did not try SQL Express 2017

sql express local db 2017 has an issue atm. We are working on it.