Numberpad does not pass number

I would like to print a number on a ticket,
I added Invoice Fattura N°:{SETTING:NUMBERPAD} but I did not press the number

works on v3, on v4 no!

Have you tried saving the Numberpad as a Ticket Tag then print using the Ticket Tag ?

in v3 was not necessary, was part of the number on the keypad and printed it.
in v4 you have to save?

Something has changed a little with NumberPad in V4.
Are you printing from the Ticket Screen or Payment Screen?
And what version are you using ?

Ticket screen, version 4.1.29

Try {Numberpad} instead.

no, not even with numberpad!

I’ve changed my template

Typed a number and clicked Print Bill

It printed.

So it seems something is different on your setup. For example Display Ticket action resets numberpad. Maybe you are using it before printing. Please let us know what might be different on your configuration.

Please also check you are modifying correct template.

the problem was just that!
before printing, you changed the settings of the program and it erased the numerator.
to overcome this problem how can you do?
I tried to execute before the printing process, but should not be!
thanks

Are you calling Display Ticket action before printing? If so you can change sort order of actions.

Alternatively you can copy NUMBERPAD setting to a different setting by using Update Program Setting action and use this setting instead.

I run the print job with the open ticket,
But at the same time update the setting program and update a ticket tag!

Can’t understand that. PM me a backup of your database so I’ll see how it configured.