Order NO resets after work period?


I just want to know what does Order NO in the printing template refers to and how is it different from “Ticket NO” ?

I do get that the Ticket NO always remains unique, but how can i configure the “Order NO” to be such that it starts from 0 at the start of every Work Period? And what syntax should i write on the receipts so that the Order NO is printed on them?

Is this what you are looking for worked for me

1 Like

Thank you so much!
That’s exactly what i was looking for!

I followed the same exact steps - it’s doing everything other than printing the order NO numeric!

Is there anyway to check if it’s being calculated or not?

I just noticed that in SambaPOS 4 there is a new Tag - which might not have been present when the tutorial that you’ve pasted earlier was printed. Should the following tag be used instead? Or some other variant of it, because this also is giving the same result.

{TICKET TAGN:X} Numeric Ticket Tag

i tried ,bur its not working how can i do this
printer template header or create a new template for printing a small paper that shows the customer order number…

Did you write it down like this {TICKET TAG:Order No}.

Yes! Doesn’t work :frowning:

Can you make a screenshot

You can see here that nothing is printed next to order number in the receipt. Where am i going wrong?

b.pdf (13.5 KB)

i have a same problem

just add maps 2 rules ,after work…use this one{TICKET TAG:Order No}

If it’s not printing the Ticket Tag, then maybe the Ticket Tag isn’t being set when you create a new ticket.
Can you show us a screen shot of the POS screen before you close the ticket.

This is what it looks like:

You are not setting the Ticket Tag - Order No when the ticket is created.

1 Like

Thanks! Its fixed now!

I hadn’t mapped the command.

I have same problem how did you fix this issue?

please help

Goto Rule List > Under “Ticket Created” i’ve named it " Give Ticket Number" > Goto Mapping and make sure its mapped to both terminals/departments etc.

1 Like