Preset terminal department

Hello again. I have a small issue. I have two departments; restaurant and bar. Only the admin, manager and supervisor have permissions to change depatments. Waiters and cashiers can not. Issue is that it seems that restaurant is the default department because after every login, the restaurant deparment is the active deparment. Is there a way to instruct sambapos that a certain terminal belongs to a certain department, so that after a user logs in the correct department is acrivated automatically? As at now, if a bar cashier logs into the system? In the POS area they are presented with the restaurant menu.
The system is scheduled to go live this weekend so i need to fix this issue fast.
Thank you all for all your assistance so far with special appreciation to @QMcKay and @emre

If you have different Departments, you have different Ticket Types (and likely different Menus), correct?

Set the Department Ticket Type and Menu:

Manage > Settings > Departments

Set the Terminal Menu (within your “other” Ticket Type):

Manage > Tickets > Ticket Types > Menu Mapping
1 Like

Thank you. Had not thought of it that way. Will implement it once i get back.

Hi, I followed your instructions but still not working. The entity screens display correctly but the menus do not. When i select an entity from the bar entity screen, i am still presented with the restaurant menu. I have changed the terminal name in local settings to bar waiter

Now working. Found where the fault was. I have cleared the default menu under department settings now it is running as required.