Problem with SAMBAPOS V5 setup

Im trying to configure V5 with Data Backup of V4 … Using tutorial of migrate data.

The simplest thing to do is just ensure you have 4.1.82 installed and backed up, then download V5 and it should update your database for you so you can just sign in. Im sure thats what i did

Im sure i got 4.1.82 installed and backed up, but its 2:00a.m. here, im gona try tomorow with fresh mind and let you know, thanks for you reply.

Just to put an update in - I have EXACTLY this problem.

For the devs: I am using the sa user in SQL. It creates table “dbo.VersionInfo” then comes up with that error. This is on a new install.

I’ve tried editing the connection string within settings, and get that error, I’ve also tried updating it from the settings text file in ProgramData. Same error each time.


  1. Rename Database value as a non existing database to force SambaPOS create a new database.
  2. After starting SambaPOS V5 restore V4 backup by using backup tool.

Here is details.

@RickH V5 uses SambaPOS5 database as default database name. So it is possible if you point V5 to V4 database but migrating by restoring V4 backup is much more safer.

@emre it’s a totally new database & instance. In fact it’s a new computer. Therefore, there is no old database to rename. SambaPOS creates the first table, then throws an error.

I got mine working by installing version 4, pointing it to a SQL database, then installed version 5 over the top.

@Bryn_Moorhouse If it does that nobody will be able to install V5 on their computer. There is probably something different on your side. I’ll appreciate if you can give more details about your system or the error message you receive.

Keep in mind that error also says “or you do not have permission” that is a huge indicator that well you setup SQL server SA account wrong without correct permissions.

@emre Windows 7 Pro SP1 with SQL Express 2014. I’ll post an exact error tomorrow when I’m back with the PC. I reinstalled the OS twice though to be sure that it wasn’t something daft.

@Jesse I understand that, but it creates the V4 database fine, and manages to create 1 table in V5, then throws an error. The sa account is setup correctly. I’ve given it every possible permission just to be 100% sure. So I find it unlikely that it’s permissions related.

Oh, and it says it can’t find the table dbo.Payments because it doesn’t exist, which when I look in the management console, it doesn’t exist.

Did you try running it as Administrator?>

It clearly creates database but can’t add tables in it. So on second run it thinks it should migrate database but required tables does not exists.

Unilke V4, V5 executes this SQL command to alter database transaction level.

if serverproperty('EngineEdition') <> 5 execute sp_executesql N'alter database [SambaPOS5] set read_committed_snapshot on'

You should be able to execute this query.

1 Like

I dont know how, but when i delete the file sambasettings to open the program and force SambaPOS to create a new data base, (like emre said) the program start perfect and the data still there, no more startup error.

Does it happen when you restore backup? There might be issue with the backup.