Problem with Store Last Ticket

dear @emre,
Since I set the feature to store and clone Last ticket as you showed me it worked great
But now it does not work.
I do not know why now on Ticket Closing it does not store the Last ticket.
I checked all the settings and nothing has changed.
Maybe something has changed since the upgrade version of sambapos?
Thanks in advance.

Your Store Last Ticket Action does not have an Entity Name in it.

Have you tried adding a Show Message action to the Store Last Ticket ID while Ticket Closing Rule to see if the Rule is executing?

Do you have mappings correctly set for the Rule?

dear @JohnS
These settings made by emre ​​himself and it worked great until now
I suspect it is related to changes made ​​in the new version.

A new version doesn’t just break things. Sometimes rules and actions may change slightly in the background, but I haven’t seen this lately.

Debug the Rules to make sure that they are working.

@JohnS, Thanks for your help
I checked and everything works except the Rule to Store Last Ticket on Ticket Closing.
i tried adding a Show Message action to the Store Last Ticket ID while Ticket Closing Rule to see if the Rule is executing and it works.
the Update Entity Data action not updating the entity custom fields.
Also I checked and it stopped working on 16 \ 6 \ 14
On the day it was released version 1.4.38
Maybe something changed in this version.

The problem is with the Store Last Ticket Action. You are not specifying an Entity Name so it does not know which entity to update.
Enter [:Entity Name] into the Entity Name field in the Action.
Remove and add the Action to the Rule again and set {ENTITY NAME:Customer} for Entity Name.

I tried it and still not working
By the way @emre defined without Entity Name And it worked Until the upgrade to the latest version.
It could be really not about the update version but it stopped working since.

It is very strange I checked it again and it works only on version 3.1.37
on 4.1.38 Released

emre said:Update Entity data action updates ticket entity.
Maybe something changed Because of this??

@pizzaeilat4 you’re correct my recent update is the reason of this issue but honestly I completely missed that feature was used somewhere. I’ll enable it on next update. You can fix it as John suggested or wait for the next update. Sorry for that.


Thank you @emre and @JohnS so much
Either way is fine I just did what John said and it works for now.