Quick Service/Tables: Food/Retail Setup - Advanced Refunds | Aborts | NonTax Functions


#222

@kendash i downloaded the file you given and installed the version that’s needed, but its need to activate the data backup 1st to use the function Database backup function. whats the say to activate that function?


#223

I am hoping someone can help…

I installed SambaPOS4 (latest version), SQL server express 2014, and the database from above link. When I attempt to start SambaPOS4 I get the following Error…

Not sure what needs to be updated. Any ideas?


#224

Think you need to install the full sql server 2014 not the express version

From your error message its saying sql server express only supports 706 and earlier so there must be a newer or more advanced version that will run fron 707 and above which is what you need


#225

Thank you for your response. I like the ‘feel’ of this software. There’s A LOT to learn. I’ve found enough information in this forum to see the potential.

Thank’s again, I’ll post my results.


#226

It really is great and so flexible that you can do pretty much anything you want and when V5 is released there’s even more features and updates :slight_smile:


#227

I agree. I look forward to learning more. For me the best way to learn something is to dive in the deep end and thrash around until I start swimming.

My evaluation machine is old and slow, so the update will be slow, I’m guessing the fact that SQL Server express needed SP1 is the problem. I should have given windows update a shot first.


#228

its probably your version of SambaPOS. The database was made on an older version of SambaPOS you need to migrate it to the newer version.

Explain how you restored the database please.


#229

I just downloaded SambaPOS yesterday, but I was starting to wonder because I am still getting the same error. My setup file is named Samba setup4182.exe… Does that help?


#230

If you read the thread I made this a long time ago. I think it was 4.1.5x version. So to get it to work you would have to migrade it to 4.1.82. I am talking about the database not the software. Easiest way to migrate it is to purchase and activate the Database Backups module and then go to Database Backups and then options and enable migrate after restore and overwrite database options are enabled then restore the database by using the Restore from Zip option.


#231

I will be honest with you. This database was my first real accomplishment when I was a rookie. I made many mistakes compared to now. With what I know now I would never build one like I did in this database. However you can learn a lot about states and some advanced tricks with switching tickets etc. Its good to learn from but I do not recommend using it.

It really surprises me how popular it is. I will probably not release more prebuilt databases but with v5 there is something called configuration tasks. I will be sharing some good advanced configurations through this method.


#232

Now that you mention it, I do recall reading that entry about the version number… I’m still wrapping my head around this. I’m not yet at a point that I need the Database Backup module.

For now I’ll back up, and play with a basic install. I’m sure that will get me started. I wasn’t looking for a solution, just a glimpse at how a more sophisticated configuration looked. I’m sure this configurations popularity is a result of your dedication to helping others understand the setup.

Thanks for the help. I’m sure I’ll be spending more time digging through the forum for answers.


#233

Well now I’ve really done it. I decided to regroup and start with a basic Install. I uninstalled Sambapos, localDb, and sql server express 2014. Reinstalled Sambapos 4.1.82. Now when I start Sambapos I get 'Login Failed for user, and sambapos ends.

Any ideas.


#234

Default login for Admin is 1234

Show the error message you are receiving. Likely a DB permissions issue.


#235

I’m no longer getting far enough to enter password. Here’s error message…

And here’s the Log…

[General Info]

Application: SambaPOS
Version: 4.1.82
Region: en
DB: SQ
Machine: SERVER
User: Administrator
Date: 8/1/2015
Time: 3:15 PM

User Explanation:

Administrator said “”

[Exception Info 1]

Top-level Exception
Type: System.Data.SqlClient.SqlException
Message: Cannot open database “SambaPOS4” requested by the login. The login failed.
Login failed for user ‘SERVER\Administrator’.
Source: .Net SqlClient Data Provider
Stack Trace: at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK) at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean ignoreSniOpenTimeout, TimeoutTimer timeout, Boolean withFailover) at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString connectionOptions, SqlCredential credential, TimeoutTimer timeout) at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(TimeoutTimer timeout, SqlConnectionString connectionOptions, SqlCredential credential, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance) at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, SqlCredential credential, Object providerInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString userConnectionOptions, SessionData reconnectSessionData) at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection, DbConnectionOptions userOptions) at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnectionPool pool, DbConnection owningObject, DbConnectionOptions options, DbConnectionPoolKey poolKey, DbConnectionOptions userOptions) at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject, DbConnectionOptions userOptions, DbConnectionInternal oldConnection) at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject, DbConnectionOptions userOptions, DbConnectionInternal oldConnection) at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection) at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection)
at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection) at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource1 retry, DbConnectionOptions userOptions)
at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource1 retry, DbConnectionOptions userOptions) at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource1 retry)
at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource1 retry) at System.Data.SqlClient.SqlConnection.Open() at FluentMigrator.Runner.Processors.GenericProcessorBase.EnsureConnectionIsOpen() at FluentMigrator.Runner.Processors.SqlServer.SqlServerProcessor.Exists(String template, Object[] args) at FluentMigrator.Runner.Processors.SqlServer.SqlServerProcessor.SchemaExists(String schemaName) at FluentMigrator.Runner.VersionLoader.get_AlreadyCreatedVersionSchema() at FluentMigrator.Runner.VersionLoader.LoadVersionInfo() at FluentMigrator.Runner.VersionLoader..ctor(IMigrationRunner runner, Assembly assembly, IMigrationConventions conventions) at FluentMigrator.Runner.MigrationRunner..ctor(Assembly assembly, IRunnerContext runnerContext, IMigrationProcessor processor) at FluentMigrator.Runner.Initialization.TaskExecutor.Initialize() at FluentMigrator.Runner.Initialization.TaskExecutor.Execute() at Samba.Persistance.Data.Migrator.DoMigrate(String connectionString) at Samba.Persistance.Data.Migrator.DoMigrate(CommonDbContext context) at Samba.Persistance.Data.Initializer.Migrate(CommonDbContext context) at Samba.Persistance.Data.Initializer.InitializeDatabase(DataContext context) at System.Data.Entity.Database.<>c__DisplayClass21.b__0(DbContext c)
at System.Data.Entity.Internal.InternalContext.<>c__DisplayClass8.b__6()
at System.Data.Entity.Internal.InternalContext.PerformInitializationAction(Action action)
at System.Data.Entity.Internal.InternalContext.PerformDatabaseInitialization()
at System.Data.Entity.Internal.LazyInternalContext.b__4(InternalContext c)
at System.Data.Entity.Internal.RetryAction1.PerformAction(TInput input) at System.Data.Entity.Internal.LazyInternalContext.InitializeDatabaseAction(Action1 action)
at System.Data.Entity.Internal.LazyInternalContext.InitializeDatabase()
at System.Data.Entity.Internal.InternalContext.ForceOSpaceLoadingForKnownEntityTypes()
at System.Data.Entity.DbContext.System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext()
at Samba.Infrastructure.Data.SqlData.EFWorkspace…ctor(CommonDbContext context)
at Samba.Persistance.Data.WorkspaceFactory.Create()
at Samba.Presentation.Services.Common.DataGeneration.DataCreationService…ctor()
at Samba.Presentation.Bootstrapper.InitializeShell()


[Assembly Info]

PresentationFramework, Version=4.0.0.0
System.Xaml, Version=4.0.0.0
Microsoft.Practices.Prism.MefExtensions, Version=4.0.0.0
mscorlib, Version=4.0.0.0
System, Version=4.0.0.0
WindowsBase, Version=4.0.0.0
System.Configuration, Version=4.0.0.0
Samba.Services, Version=1.0.0.0
Samba.Presentation.Services, Version=1.0.0.0
Samba.Presentation.Common, Version=1.0.0.0
Samba.Domain, Version=1.0.0.0
PresentationCore, Version=4.0.0.0
DevExpress.Xpf.Core.v14.1, Version=14.1.6.0
Microsoft.Practices.ServiceLocation, Version=1.0.0.0
Samba.Infrastructure, Version=1.0.0.0
Microsoft.Practices.Prism, Version=4.0.0.0
System.ComponentModel.Composition, Version=4.0.0.0
System.Core, Version=4.0.0.0
Samba.Localization, Version=1.0.0.0
FastButton, Version=1.0.0.0


[System Info]

Operating System
-Microsoft® Windows Server® 2008 Enterprise
–CodeSet = 1252
–CSDVersion = Service Pack 2
–CurrentTimeZone = -240
–FreePhysicalMemory = 81128
–OSArchitecture = 32-bit
–OSLanguage = 1033
–ServicePackMajorVersion = 2
–ServicePackMinorVersion = 0
–Version = 6.0.6002

Machine
-SERVER
–Manufacturer = Dell Inc.
–Model = Inspiron 2200
–TotalPhysicalMemory = 1332453376
–UserName = SERVER\Administrator


######################### E N D #########################


#236

Looks like your having a mistake with connection string. What is your connection string?

Can you please explain how your restoring it? Are you using MSSMS or Database Backups module in SambaPOS?


#237

Looks like you solved that part but I’m adding this for your information.

Version 706 is SQL Server 2012
Version 782 is SQL Server 2014.


#238

I don’t know what the connection string is, It’s what ever the installation default is. I can’t even start the program to check it.

I haven’t solved anything. I just tried to go back to a fresh installation.


#239

Looks to me like your confused on how to setup Samba with SQL server. Look up my 2014 tutorial it covers everything.


#240

I finally got somewhere, but not all the way in. There was a problem with the sql server service starting. I finally uninstalled sql, and then reinstalled it. After the reinstall, SAMBAPOS was then able to start. I have since restored this Db (Using ssms). Now I do get past the splash screen and I do get to the login screen, but when I enter the admin password (1234), I get a msgbox that says ‘Check Database Version’, I am using 4.1.55 of SAMBAPOS, the Db From above link, and SQL Server 2014.

I know it is suggested to use the Db Backup tool, but is this the only way? Is there a way around this error. I am only evaluating this software for someone else, so I’m not ready to pull the trigger on the Db Backup tool.

Update:

Never mind. I found the Version.Dat File and the versioninfo table. I modified the version.dat file to match, and it let me in.


#241

Noooo :slight_smile: don’t do that. You found the hardest solution…
Please roll back that change and reinstall SambaPOS. After installation SambaPOS will update database to latest version.