Quick Service/Tables: Food/Retail Setup - Advanced Refunds | Aborts | NonTax Functions


#162

I am now adding a check for Entity Minutes… if Employee tries to clock out early less than 15 min from clocking itn… it will prompt and warn them they must be clocked in for at least 15 minutes before it will let them clock out. It is working… screenshots coming.

EDIT: I thought it was working… looks like im having issues with {ENTITY STATE MINUTES:X} It may not exist I am not sure.


#163

Small update on my management screen. I now have it set to show Duration Clocked in when you click on an employee name. It will do nothing if the Employee is clocked out or is not in a state. It only shows minutes (kind of wish it tracked seconds). It would be more accurate with seconds and it could be formatted.


#164

is it possible to obtain reporting for users within SambaPOS rather than using 3rd party such as timetrex, to show their total ‘clocked’ in time? weekly, monthly etc? Just to track the hours worked?


#165

No
it does not store state history and that is not users. What I demonstrated was employee entities.


#166

@kendash Great going. Will you include delivery department in your setup?


#167

@srijit,

Thank you, no I will more than likely not include this. If a lot of people show interest in seeing it I might consider but right now I have no need for that in my business.


#168

Sorry for slowdown on updates I am doing some cool things and I want to wait until its all finished.


#169

Take your time… Im waiting to configure my whole system till i see your final time clock setup!


#170

How do I change the currency to euro?


#171

You dont. Samba does not use a default currency… do you mean change the look of your numbers? You can change the format so it shows something other than $ if this is what your talking about… and you can change how your numbers are formatted.

Your prices, whether its euro or us or whatever are set in your products and recipes etc. There is not a currency conversion that goes on unless you specify for other forms of currency you accept that are not your normal currency.


#172

Yes its the $ to €. I am only new to SambaPOS trying to figure out all settings and stuff.


#173

Hi @kendash

I tried your database to see how you integrated Time Clock, but it is giving the error below.

I logged in with 4321.

Thanks


#174

The time clock function of this database was built with the TimeTrex integration tutorial. It was not built with my new Time Clock integration that I posted. You would need TimeTrex installed and running and you would have to follow the TimeTrex tutorial for this database to work. Furthermore the timeclock integration was before all of the EntityState logging. Entity State Logging has allowed an easier more practical time clock integration.

That error is because it can not find a specific file. The file would be {ENTITY NAME}.vbs you would know what that meant if you read the TimeTrex tutorial that I wrote.

I will be switching to releasing Database Tool files instead of full databases so this one will probably not get an update.

PS The current TimeClock integration that I am using can be downloaded as a Database Tools Import file located at Database Import Tool: Pre-Built Solutions You can safely import that to your own database it has unique naming and would not impact or change your setup. You can simply delete the rules/actions etc if you do not like it.


#175

Thank you @kendash. I will give it a try.


#176

I’ve restored your database onto my sql 2014 server and samba has a connection to it, but I’m not getting any of your design work or features. What am I doing wrong? Or I’m I just being stupid. Sorry to bother you.


#177

I think you might not be inputing the correct database name under samba database settings. When samba doesn’t find a SAMBAPOS4 or SAMBAPOS database it will autmatically create one with the name which is what is happening in your case. I cant remember what samba looks for SAMBAPOS4 or SAMBAPOS by default but you need to fix that in the settings.

@chizzybear


#178

its the only dtabase I have on sql2014 and i have entered the database name in the database string of sambapos local settings , it connects fine, i’ll reset my databases again and try again.

regards

chris


#179

Oh okay sometimes what would happen to me is I would upload the database but it was a different name then what samba was looking for so it would just create another empty database thus not showing the database you need. Thought thats what was happening in your situation.


#180

@kendash I wantg some of the features u have done, so thought to restore and export the needed files but its failed and saying some version error, so even I uninstalled samba and installed 4.1.55 still its giving error , the restore done successfully in sql, is there any txt files to import or any other way iam using sql 64bit 2014 and 4.1.88 thanks kendash .


#181

This is a pretty old version of my database. I will probably update it soon after v5 releases. My current system does not resemble this at all anymore.

What part of it interests you the most? I can probably share how to implement it.