[Resolved] Issue Connecting to the database


Last time I worked with samba was last week so bear with me if this issue has been fixed in the latest two versions as I have not had the time to install them.

When I would boot my server computer I clicked sambapos and the connection string would come up (so no connection to the db). I then would wait even thirty minuets and try again still not working. The issue I think is that I ran samba pos before the ms sql had a chance to run but there is still a bug because the samba never connects then. To fix it I have to re-install Samba and delete the settings file under program data.

Thank You for your time!

The default installation of SQLServer Express will create an Instance called SQLEXPRESS.

Installing SQL Server Local DB via SambaPOS installation creates an Instance called (localdb)\V11.0

Installing SQL Server Local DB manually (outside of SambaPOS installations) will by default create an instance called (localdb)\MSSQLLocalDB

It is good to keep in mind that an Instance is not the same thing as a Database. For example, my SQLEXPRESS Instance contains 2 Databases with the names [SambaPOS3] and [SambaPOS4]. Though there is nothing wrong with, and nothing stopping you from renaming the Instance during installation to be SAMBAPOS… just know that the Instance is not the Database.

:exclamation: The SQL Server Local DB versions do not install as a Service; instead they are simply a Process called sqlservr.exe, which you should see in the Task Manager.

If you are using SQLExpress, the Instance is shown in Services. Ensure it is set to Start Automatically.

If the Service is not shown as Started, then you have an issue with Service Startup in Windows, likely due to the way it is set to start or due to permissions.

I thought I chose start automatically during the initial install but your solution makes alot of sense. I will check it and let you know in a few days.

Thank You!

Local DB will not appear as a service. It is sqlservr.exe process.

The instance name for LocalDB is (localdb)\V11.0

If you’ve manually installed latest version of LocalDB the instance name will be (localdb)\MSSQLLocalDB

Thanks for the clarifications @emre - good to know… I’ve editted my original post to contain this information.

Okay my apologies for automatically point the finger at samba as I have now realized that my other setup works flawlessly on bootup. Ill look into it soon and update my post.

Thanks for the help. @emre @QMcKay