SambaGO Tablet cannot order more than 4 Products

Try to order from Go Tablet, it is unable to place more than 4 products on one table

Please refer to the video for reference.

Also another instance


So it is not an instance related to number of orders. Looks like maybe a connection issue with message server.

What version of sambapos are you using?

Hi @Jesse

Its on 5.3.0

I will do an update during the service, and see if I can find a gap to do the update to the latest version sambaPOS.

Apart from this, what would you suggest to we do beside the update?

It’s powered by message server. Make sure no gaps there. We can look at it on our end too.

Sorry if its a dumb question.

By saying it is powered by The messaging server,
Even if to place a Product into Shopping Cart that it requires the Messaging server to handle that?

I just asked the staff to reboot the network,
After the reboot, they seems to be able to place items into the cart with no interruption, and after placing about 7-8 products, the cart clears itself.

Also, Jesse,

Will SambaGo Tablet work over LAN, or it requires Internet connection?

I am asking this is because, the site seems to have a poor internet connection after I run a couple speedtests on the server, both up and down are under 1mb/s, I wonder if this is the cause of the problem?

Connection between SambaPOS Go Tablet and Message Server running on your POS is via local network, so your internet speed is irrelevant. Nothing is sent via internet.

As you say it improved when restarting the router, it will all be most likely down to the network. Make sure there is a good stable wifi connection across the whole venue, as this is a common reason these types of apps fail. Some parts of the venue may have a poor wifi signal. There are a few free apps you can download to help you test wifi signal strength at different locations around the venue. If you find areas with poor signal, either add some wifi extenders or upgrade the main AP to a mesh AP to give better overall coverage.

1 Like

Hi Jesse,
After some puzzling,

Still having this problem.

Then we tried some older tablets that were not updated with the recent photo changes.
they seem to be working fine.

So I have the suspicion that this is related to the photos on products.
I am reuploading photos that are less than 200kb each to see if that will solve the issue.

If you have any insight regards this, please also let me know. thanks.

No, photos are only stored on the tablet. When the order is sent to message server, it only sends a very small amount of data and its all text.

Hi Mark, Thank you so much for the help on this.

I thought as much that photos are supposed to store in the tablets when they were updated from Toffice. I think I read that on the forum before.

But the strange thing with the situation we are facing is that, some of the tablets that has no photos loaded at all seems to be working fine with the order placings.

and the ones that have recently updated with new photos are having this issue with products in card disappearing and unable to order after placed a few products in the cart. as I have shown in the videos.

I will go and change the photos anyways, as I am about half way through that.

With the Network, The site has 2 Tenda Nova MW6 in bridge mode, So the coverage shouldn’t be an issue. but I do notice slower connection on the nodes compared to the Main AP/router.

I will report back with the results.

What model tablet are you using?

Are you moving around in different places when you are trying this? You can do your tests next to the AP to see if it is working perfectly there and not from elsewhere.

There is always issues like this using extenders also, as when you use an extender it will essentially half your network speed unless you use expensive models - but that should not really matter for this use case.

I think there are probably a few network related issues happening - staff moving around with the tablets, because you have different APs even they are on the SSID, the tablet will be jumping between the AP at times, and that could be a reason for it losing connecting to message server momentarily.

I have seen issues related to losing connection to message server before with Android Mobile Client and it’s been related to the wifi connection on the tablet, so that’s why I am mainly focusing on that aspect and I think if you are on site, it would be wise for you to test this scenario in known strong signal locations (i.e. next to router) to see if it makes a difference then you can know what to investigate next. It could also be the wifi APs not being setup properly - I have seen circumstances where a customer purchased a wifi extender, plugged it in and thought it works “out of the box”, or even using WPS for setup but then it was not actually doing anything, and the tablets were still only connecting to the main router. If you say you notice poorer speed near the nodes, it could be a case that the tablet it actually not connecting to the nodes at all and instead still trying to connect to the main router. It also can be problematic as the decision on what node to connect to is by the tablet, and different wifi hardware could work in different ways - it may always favour 5Ghz - for a restaurant, sticking to 2.4Ghz is usually best as it gives wider range with lower speed (5Ghz gives higher speed but less range). You are not streaming video, so 2.4Ghz is best for this use case - you could try disabling the 5Ghz band on the APs and router, or setting a different SSID for 2.4Ghz and 5Ghz bands.

1 Like

Hi Mark, and @Jesse

Sorry just come back to you guys now, went to sleep after the problem was solved, and it was 4:30am in China, too tired to write anything properly :joy:

And what I found out was that, like you guys mentioned, it was indeed a network issue for most of it!

After my last message, I reuploaded all of the photos for the dishes and asked the on-site staff to update the tablets in SambaGO, the result was some tablets worked and some didn’t. So that ruled out that photo size is causing this.

Next I went on the Server, used the CMD to ping each tablet, I noticed that the 2 tablets that are working (with no product photo might just be coincident) that is ponging 30ms-80ms. and other tablets are either not responding at all or having a 1000ms+ response.

We reworked the Local Network setup, wired the Server to the Router rather than connected to one of the Nodes via Wi-Fi, Rebooted the Network, and just like that, one by one the tablets started to work as intended. (The internet speed via the Nodes is somehow back to an acceptable range like 8-9mb/s, before it was like 0.8mb/s)

We are using Huawei MediaPad T5

With what you said, I paid more attention to the network side, as a result, I now have instructed the staff to add another node,
as the main service area is in between 2 nodes’ coverage and has no dedicated node, I noticed that tablets sometimes switch nodes due to the distance to both existing nodes are relatively the same.

And Although the product photo size is ruled out to be the cause, but I still would suggest anyone who is using SambaGO to reduce their photo size where possible, especially if there are over 5 Tablets in the setup.
The original photos are all sized from 1.5MB to over 3MB, and there are like 50 photos, updating 8 tablets all at the same time, it is pretty network heavy, and I think the nodes was overloaded the first time when the staff was updating all of the tablets. thus, the very slow internet speed on the AP nodes.

All in All, Thank you very much for the help Jesse, Mark and Nizam

1 Like