Sambapos 2.99 and SQLEXPRESS 2012 client computer can connect with UDL but not with connection string

Continuing the discussion from SambaPOS Database Configuration:

Hi all,

I have a shop that’s still on V2.99 recently the server blew up and I had to quickly redo the installation I did 3 years ago to get back up and running the same day. redeployed the backup through SQL made all the required changes, and its back up and running on the server with all its data etc.

Doesnt matter what I do I cannot get a client PC connected to Sambapos through Sambapos.

I made all the required default SQL installation changes, i.e. TCP/IP and mixed authentication etc. stopped/started services. 2 x required SQL services is running in services.msc

Setup a UDL file on the client, connects perfectly to the database from the client.

Connection string copied from server and pasted into client, so no typos.

I tried using the server IP address in the connection string, although named pipes in functioning but no joy…

There are no networking issues as I can connect to printers on the server, Ping the server etc.

Uninstalled/reInstalled samba on client, no joy…

I read every forum topic on connections from v2 forums to these ones, I cannot find anything I haven’t tried yet.

So since Samba is running fine on the server and can connect via UDL (sa account) from the client its got nothing to do with sambapos v2.99 and SQL 2012.

Since networking is fine via printers and ping cannot be networking.

I started looking in the obvious places, checked the connection string 100 times, even started adding the database ports and database names to the connection string (works on the server) not on the client. I always use the sever name in the connection string and not localhost, so not that.

I am hoping that someone can shed some light on what I may have missed in getting this client to work, I am busy pulling my hair out after a week of trying.



Hello Hugo. I don’t think people still using 2.99 exists here but we can help if it is something we can.
Can you show us the connection string? Do you receive an error message?

Hello Emre, Thank you for the response, as you probably know I have been on your journey since near the beginning and am busy with v5 in my latest venture but have used all the versions in between. Since the upgrade from v2.99 to V3 never materialised I decided to continue and made massive configuration changes written a hell of a lot of rules etc. decided to put a stake in the sand with that shop when the year ends backup the database and start new, but for now going to season I will need to get the client working again.

Data Source=cckpos1\cckpos;User Id=sa;Password=cckpos;

Not near the machine now but the error I keep getting is: The provider did not return a Provider Manifest Token string.


Try following this documentation step by step to ensure you didn’t missed a required step. As you’ve not mentioned that might be a firewall issue.

Also I don’t remember exactly how V2 connection string parser works but as documented here try to match your connection string to that format. For example don’t add ; character after password. Add spaces after ; chars, etc…

data source=[Server Computer Name]\[SQL Express Instance Name]; user id=[User Name]; password=[Password]

Thanks, the logic I was using is that if I can connect to the database using the connection string from the server surely that would be in the correct format and in theory should work on the client. Been through @pauln’s tutorial with a fine tooth combe… PS I dont use localhost in the string, always server name.


What operating system?

Windows 7 sp 1 (xxxxx 20 characters post)?

Can you connect to SQL server with MSSMS from the client?

havent installed MSSMS on client. in your opinion is there a difference in checking the connection from sa to database on server using MSSMS and a UDL? because the UDL test successful.

Did you run that test from the client? Never mind I see that you did. Hmm

Can you show the connect error from the client Sambapos?

The provider did not return a Provider Manifest Token string.

@emre sorry missed that, no all firewalls are turned off.

That means the string is wrong. Copy paste your string here. Then show screenshot of your database opened in MSSMS so we see the instance name. Also a screenshot from computer settings showing server computer name.

OK will do, not near that pc now but will be 1st thing in the morning. Thanks for you help guys. been struggling a week with this. from a technical standpoint I think I have it covered, must be something very very stupid or incredibly technical.

All signs point to the string. Be sure no accidental spaces etc in server name. Or spelling mistakes with both server name and instance name.

As I said to Emre, I copied the string out from the server pasted it to a notepad file on a network location copied the string out and pasted it. works on the server… (not using localhost)I have setup this system so many times, this is the first time in maybe 30 times, I cannot get my head around it.

I know I’ve been there myself. Usually ends up being something dumb that I did.

Try server IP address instead of name maybe?

Have tried that, research suggest that only really an issue if named pipes are not functioning.

1 Like

Try upgrading to SQL express 2014.

let me add the screenshots tomorrow morning then we see if I haven’t made a school boy error.