Sambapos v4 error when starting new period


Just complete successful transfer of ms sql from my local server to the new dedicated server with the same os and sql version. Everything looks fine until when i try to start new period, then i receiving this error

There is a problem

An error occured while updating the entries. See the inner exception for details.

And the log file:

[Exception Info 1]

Top-level Exception
Type:        System.Data.ProviderIncompatibleException
Message:     An error occurred while getting provider information from the database. This can be caused by Entity Framework using an incorrect connection string. Check the inner exceptions for details and ensure that the connection string is correct.
Source:      EntityFramework
Stack Trace: at System.Data.Entity.ModelConfiguration.Utilities.DbProviderServicesExtensions.GetProviderManifestTokenChecked(DbProviderServices providerServices, DbConnection connection)
   at System.Data.Entity.ModelConfiguration.Utilities.DbConnectionExtensions.GetProviderInfo(DbConnection connection, DbProviderManifest& providerManifest)
   at System.Data.Entity.DbModelBuilder.Build(DbConnection providerConnection)
   at System.Data.Entity.Internal.LazyInternalContext.CreateModel(LazyInternalContext internalContext)
   at System.Data.Entity.Internal.RetryLazy`2.GetValue(TInput input)
   at System.Data.Entity.Internal.LazyInternalContext.InitializeContext()
   at System.Data.Entity.Internal.InternalContext.ForceOSpaceLoadingForKnownEntityTypes()
   at System.Data.Entity.DbContext.System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext()
   at Samba.Infrastructure.Data.SqlData.EFWorkspace..ctor(CommonDbContext context)
   at Samba.Persistance.Data.WorkspaceFactory.Create()
   at Samba.Presentation.Services.Common.DataGeneration.DataCreationService..ctor()
   at Samba.Presentation.Bootstrapper.InitializeShell()

Inner Exception 1
Type:        System.Data.ProviderIncompatibleException
Message:     The provider did not return a ProviderManifestToken string.
Source:      System.Data.Entity
Stack Trace: at System.Data.Common.DbProviderServices.GetProviderManifestToken(DbConnection connection)
   at System.Data.Entity.ModelConfiguration.Utilities.DbProviderServicesExtensions.GetProviderManifestTokenChecked(DbProviderServices providerServices, DbConnection connection)

Inner Exception 2
Type:        System.Data.SqlClient.SqlException
Message:     A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 28 - Server doesn't support requested protocol)
Source:      .Net SqlClient Data Provider
Stack Trace: at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
   at System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, Boolean withFailover)
   at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean ignoreSniOpenTimeout, TimeoutTimer timeout, Boolean withFailover)
   at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString connectionOptions, SqlCredential credential, TimeoutTimer timeout)
   at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(TimeoutTimer timeout, SqlConnectionString connectionOptions, SqlCredential credential, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, SqlCredential credential, Object providerInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString userConnectionOptions)
   at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnectionPool pool, DbConnectionOptions options, DbConnectionPoolKey poolKey, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
   at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry)
   at System.Data.SqlClient.SqlConnection.Open()
   at System.Data.SqlClient.SqlProviderServices.UsingConnection(SqlConnection sqlConnection, Action`1 act)
   at System.Data.SqlClient.SqlProviderServices.UsingMasterConnection(SqlConnection sqlConnection, Action`1 act)
   at System.Data.SqlClient.SqlProviderServices.GetDbProviderManifestToken(DbConnection connection)
   at System.Data.Common.DbProviderServices.GetProviderManifestToken(DbConnection connection)

Can someone hele me?

Thank you.

It’s not connecting to the database by the looks of the log.

Thank you for your reply.

I m not sure about that because if i go to manage tab i can see all my data.
Do you have any idea how to fix it?

Thank you again

Have you tried to load from the backup again incase it loaded wrong?

We’re the work periods ended before you backed it up?

Did you update to the latest v4 before backing up?

That’s all the suggestions from me. That’s as far as my knowledge goes.


I’m wondering if you backed up then updated then loaded the backup so maybe the fields changed from one version to another in the database and so the database loaded is an older version than the updated version.

Thank you for your reply again.

I install both SambaPOS 4.1.82 same sql (from the same setup file so is the same sql ver 100%)
Than i follow sql server import and export wizard from my local server to the dedicated server, everythinks was fine (Success 100%)
I can see all my data ( users, tables, customes) but i cant start new period


I can’t help any more as it’s beyond my knowledge. Sorry.

no problem my friend.

Thank you for your time

In fact try this.

Go to local settings. Database.

Edit connection.

Datasource: localhost\SQLEXPRESS(if local host is your host and name is your instance name)

User id: sa

Password: sambapos

Database: sambatest

Wait for it to say connection established then apply

When it’s done log out log back in and run the backup.

I’m wondering if you maybe queried the backup instead of updating via samba?


I done it already.
With fresh db everything is good.
The problem is only with my db and i dont know why.

Doing the above will create a new DB


yes i know… and working perfect but without my data.

Once you get it working perfectly then use Database Backups module to import your backup and be sure migrate after restore option is checked as well as allow overwrite.

The SQL installer from SambaPOS is not a dedicated SQL Server. If you installed that then you are installing localdb version. Likely it is not connected to your standalone server. Localdb SQL is single terminal only.

Thank you my Friend.
I solved my problem!

you are real leader! :smiley:

Thank you all for your time

1 Like