Sambapos4 string problem

Hallo @morshed1, the messaging service does not want to start.I have tried 8080 and 8383. Error message reads as follows:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Net.Sockets.SocketException (0x80004005): Only one usage of each socket address (protocol/network address/port) is normally permitted
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.Net.Sockets.TcpListener.Start(Int32 backlog)
at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupChannel()
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel…ctor(IDictionary properties, IServerChannelSinkProvider sinkProvider, IAuthorizeRemotingConnection authorizeCallback)
at System.Runtime.Remoting.Channels.Tcp.TcpChannel…ctor(IDictionary properties, IClientChannelSinkProvider clientSinkProvider, IServerChannelSinkProvider serverSinkProvider)
at Samba.MessagingServer.frmMain.StartServer()
at Samba.MessagingServer.frmMain.button1_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/SambaPOS4/Samba.MessagingServer.exe

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

Assembly Version:
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/SambaPOS4/Samba.Infrastructure.DLL

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

The error message says:

You need to install message server only on server and you should either use service or stand alone server. I think multiple instances of message server running.

@emre How do I stop the other services? An where?

You’ll use Samba.MessagingServerServiceTool.exe to start stop service.

as @morshed1 said you can find details here

I have done that, the error message is what I get. I have installed it only on my server computer and not on the others. The Sambapos program keeps showing the red message"Message server not Connected. I have first used 8080, when that didn’t work I used 8383. Still no connection. Inside Sambapos the message server port is set to 8080. Do I have to change it in both places?

you receive the error message because you have multiple samba message server running (you can identify this by the icon on the bottom right corner)… i believe the error message is similar to below… can you close the Samba Massager server.

Below is my settings: it should be something like below…

1 Like

@morshed1 Thank you, I will look at it in the morning and let you know if I still have problems.Have a great day/evening.

I have stopped all message server that were working, I still have the same problem " Message Server not Connected"

can you provide screen capture of your settings? also have you tried re-starting both Smaba Message Server?

@morshed1 I have found the problem! The Message Server Name was wrong, I have tried localhost and server-pc, but that was wrong, it has to be my computer name. POS1-PC. Thank you for your help, I appreciate it very much.

@Bonamanzi, good to know its all working… enjoy

1 Like

@morshed1, with the setup of computer 2. I cant get in. I set it up like this:
Server instance name: POS1-PC (that is the name of computer number one- The server)
User Id:sa
Password: sambapos
Database: BonamanziGH(that is the database I set up on Server Computer)
The string looks like this: Data Source: POS1-PC\SAMBAPOS3; User Id: sa; Password:sambapos; Database: BonamanziGH;

Error message: Cant connect to database with current string. An error occurred while getting provider information from database. This can be caused by Entity Framework using an incorrect connection string.

Server Computer working perfectly.

You need to turn off Windows Firewall in Control Panel.
Windows Firewall is blocking access to SQL Express.

@JohnS Firewall is off, I turned it off in advanced settings. Are my settings for the string correct for computer no. 2 (Bonamanzi-Bar)-Computer 2 name

@Isaac No my server pc name is POS1-PC and my second pc name is Bonamanzi-Bar. My server pc sambapos is working perfectly. I’m trying to set up my second pc.

Under [MyDocuments]\SambaPOS4 folder of your second pc you’ll find a log.txt file. Can you zip and attach it here? It might give a better idea about the problem.

1 Like

Do you have

Data Source : POS1-PC......


Data Source = POS1-PC.....

It should be an equals (=) sign to work

@Bonamanzi, see below example how I have configured my system.

Server Configuration: (Computer 1)

Computer 2:

@emre File not attached. error message:
Sorry, the file you are trying to upload is not authorized (authorized extension: .jpg, .jpeg, .png, .gif, .zip, .pdf).

Can I send it to via email?

Did you converted it to a zip file?