Setting default menu to department does not work


I created a separate menu for takeout orders as not all items are available for takeaway. This menu has only one category.


Then, I set the default menu of takeaway department to the newly created menu


But as you can see, all the categories are still visible.

Is there anyway to fix this?

Try this.

Go to Manage > Tickets > Ticket Types > Take Away Ticket and make sure the POS Menu selected is correct.


1 Like

Did you logout and log back in and check?

1 Like

Did that but still the old menu is showing

Logged out and restarted sambapos but still the same issue.

BUT once I take an order, the menu for that entity changes but remains same for all other entities

So basically it is still possible to take any item as takeaway as long as it is entered first.

This is the takeaway department screen

Check your Ticket Type’s Entity Type List.


It was like this before, I checked the copy field like yours

Restarted sambapos and it still doesn’t work. The menu changes only after selecting items.

Are you selecting Customer from the default customer search screen?

If so, you may have to create a Take-A-Way Customer Search screen. You can still use your existing customers.

Go to:
Manage->Entities->Entity Screens->Add Entity Screen

Where I have Pro Shop…replace with Take Away.


You may want to change the Default Customer Search Entity Screen to be mapped to all Non-Take Away department(s).

Your newly created Entity Screen should look like the default customer search screen.

I had the same situation. This is what I did to fix the problem.

1 Like