SQL Express trough network

So basically I have SQL Express installed on one computer, along with SambaPOS4, and let’s call this computer CUISINASERVER.

On the other hand, we have CUISINACLIENT that I have SambaPOS4 there installed for regular use.

I’m connecting my client to the server using the following line.

Data Source=\CUISINASERVER\SAMBAPOS4; User Id=sa; Password=******; Database=SambaDataServer;

CUISINASERVER appears on my client network page.

All details up are correct, but is the syntax?

The computer connection name is CUISINASERVER\SAMBAPOS4 database is SambaDataServer


It should be
Data Source=SERVERNAME \ INSTANCE NAME; User Id=sa; Password=******; Database=DATABASE NAME;

What is the setting on the server?
It would show you all exc server name as would most likely be localhost \ INSTANCE NAME

Used it, not working.

Do I need to open some kind of a firewall thingy?

The Server name and Instance shows up in MSSMS when you connect to your database it looks like this.

So as you can see my Connection String would look like this:

Data Source=MANCOW2\SQLEXPRESS; Database=DairyCreme

I did not include Password or User Id because I am using windows authentication. However if your using mixed mode you can include those.

You need to ensure a few things are working first.

1. in MSSMS right click your server and choose properties then go to Connections and ensure Allow remote connections to this server is enabled.

2. Ensure the following services are active and running.
SQL Server Browser
SQL Server Agent

3. Go to run and type mmc and press enter to open the Microsoft management console. Go to File > Add new snapin and choose SQL Server Configuration manager

4. Expand the Native CLient 11.0 and click on Client Protocols and ensure TCP/IP is enabled.

Is your firewall on? (on the server machine)

I’ll give you the details.

Server Computer Name: CuisinaServer
“Instance Name”: SambaPOS4 (Like the tutorial)
Database: SambaDataServer
Username: sa
Password: 1234

Not anymore, I switch it off

Can you ping the server from the ‘client machine’?

Read my threads above.

Thanks, but I can’t find the snap-in SQL Server Configuration Manager to add it, everything else is okay

Its usually near bottom of list just above Task Scheduler

What if I can’t find it :confused:

If you still cant find it then try typing this in a search to find it on your computer.


What version of SQL Server Express are you using?

Can’t find it, yeeeeeey

It’s Microsoft SQL server 2012 11.0

Hey don’t kill me, that was in the tutorial

1 Like

It should be there but I recommend installing the newest version which is 2014. You probably used the outdated tutorial here is the newest one I wrote.

You can also just choose upgrade to upgrade 2012 to 2014

SQL EXpress 2016 will be out soon as well probably this year.

I recommend checking the services specifically SQL Server Browser if thats not running it will not work at all regardless if TCP/IP is enabled or not. Typically its enabled by default…

You should disable firewall on both server and client until you can get it connecting… once you get it connecting you can configure forwards to allow the firewall to skip the specific ports.

Which ports, I have my firewall disabled as other post I read said it was hard to open SQL ports as they were dynamic?

They are certainly not dynamic.
default port is 1433

You can find this information by looking at the TCP/IP properties from inside the MMC snapin mentioned above.

1 Like

Hmmm, fair enough, Samba is my first use of MSSQL but sure I read that elsewhere on the forum.
Nice one, want ideal having the firewall off :fearful:

Just been trying this but must have missed something.
Checked port is 1433 and it is.
Added it to inbound rules as allow.
But cant connect, if turn of firewall it works…

Is it just the one port that needs opening?

You didnt specify a protocol but a google search said TCP, changed to all prococols and it seems to work…