Ticket not print Logo

Can anyone assist me with this problem…maybe im doing wrong…

iam using Bixolon SRP-275 printer…

when i print my ticket will be look a like this

Show your printer template

-- General layout
<L00>Ticket No:{TICKET NO}
[<L00>Total Gift:|{ORDER STATE TOTAL:Gift}]

[<J10>Changed Amount |RM {CHANGE TOTAL}]
<Cxy>'Our Taste For Everyone'

<C10>T H A N K   Y O U
<Cxy>Please Visit@Like Our Page
<Cxy>Just Doner Restaurant


<J00>Cash Received  |RM {TENDERED}

-- Default format for orders



-- Format for gifted orders


-- Nothing will print for void lines

-- Format for order tags

-- Table entity format
<L00>Table: {ENTITY NAME}

-- Customer entity format
<J00>Customer: {ENTITY NAME} | {ENTITY DATA:Phone}

this one i try print the logo picture using bixolon printer

What’s with all the Cxy formatting tags?
Not to say it’s related but these should have numbers were the X and y are to define the size, C00 being the basic size.

What’s wit the last post? This one is when I print the logo? Can you explain?

Jibberish like that my first guess would be the braud rate setting was wrong but the text at the bottom is there… How have you created the bitmap? Mace you reduced the size etc?

Maybe you should try to use the utility for the printer and see if you can use the logo feature if it was it where the printer itself puts the logo at the top.

Cxy formatting tags for my restaurant address…

last post i expect my bmp file corrupt or anything else but when i print directly the logo just print fine…

when i print my ticket came out like my first post…no logo printed at my ticket…

i already use this printer utility its called NV IMAGE TOOL…my printer connect to pc using parallel-usb cable…when i choose USB port NV IMAGE TOOL give a message no printer connected…

for my logo its png and i change the file to bitmap using paint

how to setting braud rate?..

sorry im not good at this things,

It’s on control panel, right click on windows logo on the bottom left of the screen (windows 8.1/10). And choose Device manager, pick the device and right click properties, baud rate settings should be in one of the tabs.

<Cxy> is not a valid formatting tag. Change them to be <C00> as JTRTech has mentioned.

already change to <C00>

my logo still not printed

Try a smaller bitmap size.
Try setting bitmap dpi to 72 pixels.
Try 8bit images.

This topic may also help.

1 Like

still not working

is there anyone in this forum have the same problem using bixolon printer?

This is bixolon utility for put logo…after i click download, message came out “openport failed”

I think you may receive better help from bixolon.


If you are receiving an “open port failed” when using a printer utility to upload images to the onboard storage it is because you currently have the print driver installed on the printer. To fix this:

(1) Open up the printer settings and get to the port settings for the printer.
(2) Temporarily switch the “port” from its actual port to something different that is not in use. I use to switch mine to LPT1
(3) Go back to the utility and try to upload again, the port should then be available to the utility for comm to the printer
(4) Reverse steps 1-2.



Sounds like a great pro tip @josephrussell. Thank you very much for sharing.