Turned on Training mode, now SambaPOS fails to start

I turned on Training mode or at lease I though that is what I did. Tried to start the app today and now I get this error message and the system failes. I don’t know where to look or what to try to get it to the admin screen.

What logs or files can I look at to remove the training mode stuff.

Training mode works in network setup. The reason of this problem might be you are using SambaPOS in single terminal mode. Let me know if it is the case so I can try to handle it.

You can solve it by following these steps.

  1. Close SambaPOS.
  2. Edit C:\ProgramData\SambaPOS\SambaPOS4\SambaSettings.txt
  3. Find <ConnectionString>training_2824</ConnectionString> tag.
  4. Delete training_2824 part between tags. It should appear as <ConnectionString></ConnectionString>
  5. Save it and start SambaPOS.

You can also try renaming SambaSettings.txt and let SambaPOS to regenerate it.

YAY, That fixed it, SambaPOS now starts successfully.

I’ll research more on setting up training mode correctly

Thank you for the clear detailed instructions.