Update Order Group not working since update


#1

Think this has been mentioned but cant find the topic.
Just noticed since updating my course grouping has stopped working.

On live system on old 5.1.58 it works fine;

image

Not sure what version it changed but on 5.2.18 it doesnt group;

Notice there is a new field in the action for ‘Reset Key’ which isnt used on either install…

image

Any suggestions?


#2

Hmm, in trying to work out seems like i have broken grouping for new orders :frowning:


#3

So is it working now?


#4

This is what i currently have;

image

image

image

image

Am testing to work out the issue now.


#5

Hmmmm, recreated basics on fresh DB and still not working…
However get an odd space above the orders like it is grouped but not displaying…


#6

Did you do something to that order state visibility?


#7

Did you not set a key? It’s blank in your screenshot.


#8

FFS, missed the second F from the colour!


#9

But now get all as a single group…

image


#10

You have no group key set.


#11

FFS, am rushing… ORDER missed E!


#12

OK, so works as expected in fresh DB;

image


#13

So… whats wrong on main DB…


#14

image

image


#15

Checking rule debugger shows that the order state updated action isnt fireing on new orders added… :-/


#16

But is i use the 'change course option which updates order course state it does work…


#17

Disabled the update discount automation commands to check if they were interfearing but no change;


#18

@kandash any ideas? Am struggling for ideas on where to start!


#19

From screen and debugger can see the rule to set the Kitchen Course state is firing…


#20

Have unmapped/disabled with 1==2 all rules/actions not related to the course state to try and make like fresh DB but still no luck :-/

image