User role not functioning


#21

You have no customer selected to the ticket.


#22

To selected customer is faded too, cannot be clicked look at the images


#23

Ok so you messed up your ticket type settings looks like. Go to Settings > Tickets > Ticket Types and make sure customers is assigned to your ticket type.

EDIT: NM TIcket is locked you need to unlock ticket to add customer. Press Unlock Ticket button and try.


#24


#25

The change table option was enabled after unlocking the ticket. Selected customer is still faded can’t be clicked


#26

Hmm if you login as admin will it let you?


#27


#28

Ok so for your user you need to check permissions is can change entity enabled for that users role?


#29

I logged in as administrator and everything works perfectly


#30

Yes so your problem is that you have restricted the user role so it can not add or remove an entity from a ticket. It had nothing to do with customer payment. Check those permissions and see if it fixes it.

Also be sure and enable Can Create Account option too.


#31


#32

I clone admin role for the user.


#33

Why do that… just make user an admin…if thats what you want.


#34

Can you show mapping for the “Customer Search” entity screen? User need to have permission to access to a customer entity screen to be able to select one.


#35

It worked, thanks alot.


#36

What did? Emre’s suggestion? I wasnt serious about making them admin.


#37

Making them admin worked.

This is the only solution I have seen, i have battled with is issue for long.


#38

Please try what Emre said above… Making them admin really doesnt fix it. It may cause you even worse headaches later.


#39

Go to Settings > Entities > Entity Screens > Customer Search and click Mappings show us whats there.


#40

Perfect thanks alot sirs for your assistance.

What emre, suggested worked.