V5 Check Database Version - not resolved by Mar 16 posting

Did you tried setting a network path as backup location that is accessible by all terminals and server? Does it shows an error message?

Hello Everybody

m having the same problem but thing is i tried every verion 5158,5160,5162 and the latest V5 pro from website. the problem is when m installing old versions its saying check database version and when m installing latest one its not connecting to the database. Now interesting thing is when i put connection strings for the first time in latest version it says connect successfully but when i save it and restart it shows me this:

Now the situation is i cant open my database from any version of samba.

What’s you full connection string?
Check SQL service is running.

yes it is running and my connection string is:

I tried to backup my main data and deleted it, then i open samba with the latest version and its opening but if i replace the database it says same cant connect to database.

So check you have correct instance, user password and database by logging in to SQL using SQL Manager.

did that already everything perfect.

Show full connection string and a screenshot of SQL Manager db list

Step 1:

Step 2:


If you see in this picture that its giving a error that this sql transaction has completed. i saw this error when i was putting string and press apply insted of save. is there any problem with this?

Not sure if it’s case sensitive but your database name is not same case as connection string…

my database is 2014 so try to install 2016 and run database on it?


any help you could provide?

Am I talking to myself! Your db name is not the same case as the DB shown in SQL Manager.

If you talking about SambaPOS5 then i check it already it doesnt matter if its case sensitive.

this is the error on 5158 and 5160 versions and its connecting to database correctly.


any help would be appreciated please.

Your trying to use a database from a different version of samba that’s why it wont open, and that’s what that error message is

You need to find out which version of samba that database was last backed up in, install that version, your database should then open

Then install latest version and it will upgrade your database

But your first need to find out which version of samba your database was backed up in so it opens

Your connect string is wrong. Do not use local host. Use the ip or computer name.

So Data Source=DESKTOP-SV1DESC\SQLExpress

Or Data Source=192.168.1…\SQLExpress. Fill in your actual IP