Virtual Work Period - Not starting after 'Clear Transactions'

I just ran clear transactions from the DB tools and the virtual work period won’t start. I tried restarting and nothing. After that I went to Work Periods to start one and it states:


After ending W/P the Virtual W/P doesn’t start


I then go to set up VWP and its already enabled. With this done we still can’t access POS. I recall the first time enabling VWP that it showed the start time and an open work period.


Disabling and reenabling doesn’t do anything. Nothing sure whats wrong. Anyone have an idea?


It wont start until the next day and it hits that hour. Or try setting it to a few minutes from current time. if you need to start one right now.

The best thing to do is start it manually and then close it manually and the next day it will pickup at set time.

Remember its set to start at specific time you specify not before.

Does it only automatically start the first time?

It starts at set time. Next time you clear database transactions, disable VWP then clear then start a wp and set VWP again. Otherwise you need to manually start one and manually stop it when your finished and the net time it hits that defined start hour it will start automatically.

It is designed to allow manual stop of work period so you can do Inventory Corrections with EOD reports. It will pick back up and start a new WP the next day at specified time.

Clearing Database transactions messes with that flow.

Got it. Just got me concerned I messed something up. So start a work period and then make sure to close it prior to the start of the automatic period?

Believe me nobody has messed things up more than me haha. Yes you will be fine the next morning after you manually stop the WP the night before.

@Jesse It didn’t start the workperiod this morning. I double checked at its enabled set for 6. When going to POS it asks me to start a work period. Any other ideas?

You ended the WP manually? Something got it out of sync let me see if I can recreate that issue here and work out a plan for it. Ill respond back to you in a moment.

Yep. I ended it this morning at 2am.




I am testing that now. Ill get back to you in a moment.

Can you confirm it was after 6am when you checked it?

The screen shots above are from 8am this morning if thats what you’re asking.

Yes thank you. I have reproduced it… I am now trying to understand why its happening. I have an idea why but I will confirm it in a moment.

I have to wait for 20 minutes to confirm my suspicion. 11am my time.

Thanks Jesse. I appreciate it.

Joe leave it enabled and try closing manually again tonight. Lets let it cycle through again. I am still testing it.

For some reason it did start this morning. In the future if you want to clear transactions with a virtual work period, can you confirm the steps?

  1. Stop the work period.
  2. Clear transactions.
  3. Virtual work period should automatically start up at the next scheduled time.