Why Print Report Action Error


#1

I created a management entity screen with 2 Report Viewer Widgets and 2 Automation Command Button employing Print Report Action but I think the date range passed to it is not correct.

Print Period Report Button Error 3


#2

It helps if you show us the error.

Edit: oh there was no error it’s just not printing as desired. Is work period closed when you used the button?


#3

The error is in the report in the first pic where the data is January 1, 0001

I will circle that and repost the pic in a sec.

Note the report on the left of the 1st pic shows the report with the correct intended date on the screen but when printed using the button I create above, the date for the report is wrong.


#4

So is work period open or closed? Also did you try actually printing it? Finally what version of Sambapos are you using?

An error would have a popup or log indicating an error. You may have uncovered a bug but we need to be sure.


#5

Should be open as I can continue to enter tickets. However, when I go into"Work Period", both open and close period are grey out.


#6

That just means you have open tickets. Try closing wp then print it.


#7

Still using the date jan 01 after period is closed.

I thin it is not recognizing the option “Work Period” in the Data Range field.


#8

Did you try printing it and not using notepad?


#9

I did not because I have no printer at home.

The notepad did work with the standard “print” in the “Work Periods” module though.

Will try to get junk printer to see what happen.


#10

Tested using other option/selection in the Print Report action.

All other options like 'This Week", “This Month”… work except “Work Period”

Do you guys have the same results or just my setups?

If it is not just my setup having issues, then it should be a minor bug waiting for some work arounds


#11

It is a bug with the Print Report action. Instead of using Work Period, just leave the field blank.

The bug was discovered by another user in a different topic, and has been reported.