Why this Change Ticket Entity not working?

I try to automate create ticket and set entity for ticket but it doesn’t work (no entity was changed). I need to manually click Change Entity button so the entity will change. Obviously, the rule is working (when manually click) but not when fully automate.

==============

I create 2 rules (rule 1 will trigger rule 2) and also a button to manually execute the rule 2.
Rule 1



Rule 2.

BTW, I try add item before click Change Entity as well to make sure screen refresh.

Try setting Update Null Entity to True.

Or you might want to Create and Update the Entity first, then Select Entity, then Create Ticket

I did set Update Null Entity but no luck. Actually, it already have entity created but it still not select.

BTW, it weird that I have almost the same setup with select Table (Create Ticket->Change Ticket Entity) and it work. So, I create Customer entity but it doesn’t work hmmm.

EDIT: I tried Change Ticket Entity -> Create Ticket but still not working. Well it should not because Chabge Ticket Entity before having ticket.

Have you tried setting the Execute Automation Command Background to False (last Action in first Rule)?

Try both True and False. Also,deley and not delay.

EDIT: Wait I think there is something wrong with Action. I will delete and try again.
Because I did this and it is not working.

Set Table Name is hard code action and Change Ticket Entity is generic. It is weird.

EDIT2: It is working now. Have to delete Action and start all over.

1 Like